aboutsummaryrefslogtreecommitdiff
path: root/net/mrouted/Makefile
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2006-09-28 21:29:10 +0000
committerBruce M Simpson <bms@FreeBSD.org>2006-09-28 21:29:10 +0000
commit51a04cbd4c5ca6dc3d46e787406c076ac671ff67 (patch)
tree4105192f5ff7380f4e849cf97330664c6fa9d21c /net/mrouted/Makefile
parent7cf3d9082da0ecf9dc89a98fd65a7f036224b1bb (diff)
Notes
Diffstat (limited to 'net/mrouted/Makefile')
-rw-r--r--net/mrouted/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net/mrouted/Makefile b/net/mrouted/Makefile
new file mode 100644
index 000000000000..96f684e0ae2a
--- /dev/null
+++ b/net/mrouted/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mrouted
+# Date created: 28 September 2006
+# Whom: Bruce M Simpson <bms@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mrouted
+PORTVERSION= 3.9
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.research.att.com/pub/fenner/mrouted/ \
+ http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/distfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION}beta3+IOS12
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Multicast routing daemon providing DVMRP for IPv4
+
+USE_RC_SUBR= mrouted
+BUILD_ENV+= CFLAGS="-O2 -fno-strict-aliasing -DRSRR -Dlog=logit"
+
+MAN8= map-mbone.8 mrouted.8 mrinfo.8
+
+MROUTED_BINARIES= map-mbone mrouted mrinfo
+
+PLIST_FILES= sbin/map-mbone sbin/mrouted sbin/mrinfo
+
+do-install:
+.for i in ${MROUTED_BINARIES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/sbin/${i}
+.endfor
+.for i in ${MAN8}
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${PREFIX}/man/man8
+.endfor
+
+.include <bsd.port.mk>