aboutsummaryrefslogtreecommitdiff
path: root/net/mrouted
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-10-17 04:01:01 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-10-17 04:01:01 +0000
commitf1393f84fb581caef1a013016136549c8d342c5c (patch)
tree4e6ee10cd3e03190791fa22ea0b3c64d19c7d62f /net/mrouted
parentb07545a0d4b4267100db93ca83a6a1459176965e (diff)
downloadports-f1393f84fb581caef1a013016136549c8d342c5c.tar.gz
ports-f1393f84fb581caef1a013016136549c8d342c5c.zip
Notes
Diffstat (limited to 'net/mrouted')
-rw-r--r--net/mrouted/Makefile15
-rw-r--r--net/mrouted/files/patch-Makefile20
2 files changed, 26 insertions, 9 deletions
diff --git a/net/mrouted/Makefile b/net/mrouted/Makefile
index 4c960ea0d85f..ad22d1bf492c 100644
--- a/net/mrouted/Makefile
+++ b/net/mrouted/Makefile
@@ -18,16 +18,17 @@ USE_BZIP2= yes
USE_GMAKE= yes
MAKE_ARGS= sysconfdir=${PREFIX}/etc \
mandir=${MAN8PREFIX}/man/man8
-
-MAN8= map-mbone.8 mrouted.8 mrinfo.8 mtrace.8
PORTDOCS= README AUTHORS ChangeLog
-
PLIST_FILES= sbin/map-mbone sbin/mrouted sbin/mrinfo sbin/mtrace \
- etc/mrouted.conf
+ etc/mrouted.conf man/man8/map-mbone.8.gz \
+ man/man8/mrinfo.8.gz man/man8/mrouted.8.gz \
+ man/man8/mtrace.8.gz
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
-.ifdef NOPORTDOCS
-MAKE_ARGS+= datadir=${WRKDIR}/doc
+.if ${PORT_OPTIONS:MDOCS}
+MAKE_ARGS+= datadir=${DOCSDIR} doc=yes
.endif
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net/mrouted/files/patch-Makefile b/net/mrouted/files/patch-Makefile
index a4dd301c7c4e..17a99e1a2c67 100644
--- a/net/mrouted/files/patch-Makefile
+++ b/net/mrouted/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2013-01-02 08:02:25.000000000 +0900
-+++ Makefile 2013-01-02 08:02:30.000000000 +0900
+--- Makefile.orig 2011-10-23 17:03:36.000000000 +0900
++++ Makefile 2013-10-17 12:59:19.000000000 +0900
@@ -51,7 +51,7 @@
$(MTRACE_OBJS) $(MSTAT_OBJS)
SRCS = $(OBJS:.o=.c)
@@ -9,3 +9,19 @@
LINT = splint
LINTFLAGS = $(MCAST_INCLUDE) $(filter-out -W -Wall -Werror, $(CFLAGS)) -posix-lib -weak -skipposixheaders
+@@ -70,13 +70,13 @@
+ install: $(EXECS)
+ @install -d $(DESTDIR)$(prefix)/sbin
+ @install -d $(DESTDIR)$(sysconfdir)
+- @install -d $(DESTDIR)$(datadir)
++ @[ -z "${doc}" ] || install -d $(DESTDIR)$(datadir)
+ @install -d $(DESTDIR)$(mandir)
+ @for file in $(EXECS); do \
+ install -m 0755 $$file $(DESTDIR)$(prefix)/sbin/$$file; \
+ done
+ @install -b -m 0644 $(CONFIG) $(DESTDIR)$(sysconfdir)/$(CONFIG)
+- @for file in $(DISTFILES); do \
++ @[ -z "${doc}" ] || for file in $(DISTFILES); do \
+ install -m 0644 $$file $(DESTDIR)$(datadir)/$$file; \
+ done
+ @for file in $(MANS); do \