aboutsummaryrefslogtreecommitdiff
path: root/net/mtr
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-03 19:57:16 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-03 19:57:16 +0000
commit46480ea4b656e171b79503deb36c39560d6a01f4 (patch)
treeefc701a773df6a1a90a84a467735803150e952c2 /net/mtr
parent7e1c0bb6d2f15c11c41b0ba2c278c4b4163beae9 (diff)
downloadports-46480ea4b656e171b79503deb36c39560d6a01f4.tar.gz
ports-46480ea4b656e171b79503deb36c39560d6a01f4.zip
Fix MTR_OPTIONS parsing
- Bump PORTREVISION for package change Reported by: Zeus Panchenko <zeus@ibs.dn.ua> Obtained from: https://github.com/traviscross/mtr/commit/3649b04337d38725f58a3d8ebe7845cb7fa3cabf
Notes
Notes: svn path=/head/; revision=489206
Diffstat (limited to 'net/mtr')
-rw-r--r--net/mtr/Makefile1
-rw-r--r--net/mtr/files/patch-ui-mtr.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/net/mtr/Makefile b/net/mtr/Makefile
index 96f25e85e57c..a31ea7743b29 100644
--- a/net/mtr/Makefile
+++ b/net/mtr/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mtr
PORTVERSION= 0.92
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://www.bitwizard.nl/mtr/files/ \
LOCAL/sunpoet
diff --git a/net/mtr/files/patch-ui-mtr.c b/net/mtr/files/patch-ui-mtr.c
new file mode 100644
index 000000000000..020f056294e4
--- /dev/null
+++ b/net/mtr/files/patch-ui-mtr.c
@@ -0,0 +1,12 @@
+Obtained from: https://github.com/traviscross/mtr/commit/3649b04337d38725f58a3d8ebe7845cb7fa3cabf
+
+--- ui/mtr.c.orig 2017-02-05 07:27:33 UTC
++++ ui/mtr.c
+@@ -301,6 +301,7 @@ static void init_fld_options(
+ ctl->available_options[i] = data_fields[i].key;
+ ctl->fld_index[data_fields[i].key] = i;
+ }
++ ctl->available_options[i++] = '_';
+ ctl->available_options[i] = 0;
+ }
+