aboutsummaryrefslogtreecommitdiff
path: root/net/mtr
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-08-25 02:48:22 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-08-25 02:48:22 +0000
commited3b837072f0b8a6b2555da1de51ff4f713972e4 (patch)
treec325830f68722858acc62f78ec133d239fe06ed4 /net/mtr
parent92e1b950d902588134a7913988c83f186901bc17 (diff)
downloadports-ed3b837072f0b8a6b2555da1de51ff4f713972e4.tar.gz
ports-ed3b837072f0b8a6b2555da1de51ff4f713972e4.zip
Notes
Diffstat (limited to 'net/mtr')
-rw-r--r--net/mtr/Makefile35
-rw-r--r--net/mtr/distinfo6
-rw-r--r--net/mtr/files/patch-aclocal.m4398
-rw-r--r--net/mtr/files/patch-dns.c16
4 files changed, 21 insertions, 434 deletions
diff --git a/net/mtr/Makefile b/net/mtr/Makefile
index 4ddd3999fcbb..d97784d91438 100644
--- a/net/mtr/Makefile
+++ b/net/mtr/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mtr
-PORTVERSION= 0.73
-PORTREVISION= 1
+PORTVERSION= 0.74
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.bitwizard.nl/mtr/ \
http://www.mirrors.wiretapped.net/security/network-mapping/mtr/ \
@@ -17,34 +16,36 @@ MASTER_SITES= ftp://ftp.bitwizard.nl/mtr/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Traceroute and ping in a single graphical network diagnostic tool
-USE_GNOME= gnometarget
USE_GMAKE= yes
-USE_AUTOTOOLS= automake:19 autoheader:262 autoconf:262
+GNU_CONFIGURE= yes
MAN8= mtr.8
PLIST_FILES= sbin/mtr
-.if !defined(WITHOUT_X11)
-.if defined(WITH_GTK1)
-USE_GNOME= gtk12
-PKGNAMESUFFIX= -gtk1
+.if defined(WITHOUT_X11)
+PKGNAMESUFFIX= -nox11
+CONFIGURE_ARGS+=--without-gtk
.else
USE_GNOME= gtk20
-CONFIGURE_ARGS=--enable-gtk2
-.endif
-USE_XORG= x11
-CONFIGURE_ARGS+=--with-gtk-prefix=${LOCALBASE}
-.else
-PKGNAMESUFFIX= -nox11
-CONFIGURE_ARGS=--without-gtk --with-gtk-prefix=/nonexistant
.endif
.if defined(WITHOUT_IPV6)
CONFIGURE_ARGS+=--disable-ipv6
.endif
+.include <bsd.port.pre.mk>
+
post-patch:
- @${REINPLACE_CMD} -e '/getopt/d' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e \
+ 's|getopt.*$$(OBJEXT)||g ; \
+ s|getopt.*[ch]||g ; \
+ /getopt.*Po/d' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|"getopt\.h"|<getopt.h>|g' ${WRKSRC}/mtr.c
+.if ${OSVERSION} < 700024
+ @${REINPLACE_CMD} -e \
+ 's|-Wno-pointer-sign||' ${WRKSRC}/configure
+.endif
post-install:
@${ECHO_MSG} ""
@@ -54,4 +55,4 @@ post-install:
@${ECHO_MSG} "in file ${WRKSRC}/SECURITY (not installed)"
@${ECHO_MSG} ""
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/mtr/distinfo b/net/mtr/distinfo
index 9077e8cdcbd8..0737953b2fbf 100644
--- a/net/mtr/distinfo
+++ b/net/mtr/distinfo
@@ -1,3 +1,3 @@
-MD5 (mtr-0.73.tar.gz) = 52223cc34c72092a0392865356a3dc76
-SHA256 (mtr-0.73.tar.gz) = 30bdf752ac048dd160aa28d5caff1ffe0986dd4df046c397087fa1d8c8e1ab51
-SIZE (mtr-0.73.tar.gz) = 558744
+MD5 (mtr-0.74.tar.gz) = 0bc1601c9bc6f2a4af58c6b5baca4668
+SHA256 (mtr-0.74.tar.gz) = 72a01095e623b55a5223a67d8deba7595304bfe23d88d6b66d3e7784e4a7183f
+SIZE (mtr-0.74.tar.gz) = 178587
diff --git a/net/mtr/files/patch-aclocal.m4 b/net/mtr/files/patch-aclocal.m4
deleted file mode 100644
index 09d90d4cb220..000000000000
--- a/net/mtr/files/patch-aclocal.m4
+++ /dev/null
@@ -1,398 +0,0 @@
---- aclocal.m4.orig 2008-04-08 01:32:46.000000000 +0900
-+++ aclocal.m4 2008-04-13 02:57:08.000000000 +0900
-@@ -1057,3 +860,395 @@
- AC_SUBST([am__untar])
- ]) # _AM_PROG_TAR
-
-+# Configure paths for GTK+
-+# Owen Taylor 1997-2001
-+
-+dnl AM_PATH_GTK_2_0([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
-+dnl Test for GTK+, and define GTK_CFLAGS and GTK_LIBS, if gthread is specified in MODULES,
-+dnl pass to pkg-config
-+dnl
-+AC_DEFUN([AM_PATH_GTK_2_0],
-+[dnl
-+dnl Get the cflags and libraries from pkg-config
-+dnl
-+AC_ARG_ENABLE(gtktest, [ --disable-gtktest do not try to compile and run a test GTK+ program],
-+ , enable_gtktest=yes)
-+
-+ pkg_config_args=gtk+-2.0
-+ for module in . $4
-+ do
-+ case "$module" in
-+ gthread)
-+ pkg_config_args="$pkg_config_args gthread-2.0"
-+ ;;
-+ esac
-+ done
-+
-+ no_gtk=""
-+
-+ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
-+
-+ if test x$PKG_CONFIG != xno ; then
-+ if pkg-config --atleast-pkgconfig-version 0.7 ; then
-+ :
-+ else
-+ echo "*** pkg-config too old; version 0.7 or better required."
-+ no_gtk=yes
-+ PKG_CONFIG=no
-+ fi
-+ else
-+ no_gtk=yes
-+ fi
-+
-+ min_gtk_version=ifelse([$1], ,2.0.0,$1)
-+ AC_MSG_CHECKING(for GTK+ - version >= $min_gtk_version)
-+
-+ if test x$PKG_CONFIG != xno ; then
-+ ## don't try to run the test against uninstalled libtool libs
-+ if $PKG_CONFIG --uninstalled $pkg_config_args; then
-+ echo "Will use uninstalled version of GTK+ found in PKG_CONFIG_PATH"
-+ enable_gtktest=no
-+ fi
-+
-+ if $PKG_CONFIG --atleast-version $min_gtk_version $pkg_config_args; then
-+ :
-+ else
-+ no_gtk=yes
-+ fi
-+ fi
-+
-+ if test x"$no_gtk" = x ; then
-+ GTK_CFLAGS=`$PKG_CONFIG $pkg_config_args --cflags`
-+ GTK_LIBS=`$PKG_CONFIG $pkg_config_args --libs`
-+ gtk_config_major_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
-+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
-+ gtk_config_minor_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
-+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
-+ gtk_config_micro_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
-+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
-+ if test "x$enable_gtktest" = "xyes" ; then
-+ ac_save_CFLAGS="$CFLAGS"
-+ ac_save_LIBS="$LIBS"
-+ CFLAGS="$CFLAGS $GTK_CFLAGS"
-+ LIBS="$GTK_LIBS $LIBS"
-+dnl
-+dnl Now check if the installed GTK+ is sufficiently new. (Also sanity
-+dnl checks the results of pkg-config to some extent)
-+dnl
-+ rm -f conf.gtktest
-+ AC_TRY_RUN([
-+#include <gtk/gtk.h>
-+#include <stdio.h>
-+#include <stdlib.h>
-+
-+int
-+main ()
-+{
-+ int major, minor, micro;
-+ char *tmp_version;
-+
-+ system ("touch conf.gtktest");
-+
-+ /* HP/UX 9 (%@#!) writes to sscanf strings */
-+ tmp_version = g_strdup("$min_gtk_version");
-+ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
-+ printf("%s, bad version string\n", "$min_gtk_version");
-+ exit(1);
-+ }
-+
-+ if ((gtk_major_version != $gtk_config_major_version) ||
-+ (gtk_minor_version != $gtk_config_minor_version) ||
-+ (gtk_micro_version != $gtk_config_micro_version))
-+ {
-+ printf("\n*** 'pkg-config --modversion gtk+-2.0' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
-+ $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
-+ gtk_major_version, gtk_minor_version, gtk_micro_version);
-+ printf ("*** was found! If pkg-config was correct, then it is best\n");
-+ printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
-+ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
-+ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
-+ printf("*** required on your system.\n");
-+ printf("*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH\n");
-+ printf("*** to point to the correct configuration files\n");
-+ }
-+ else if ((gtk_major_version != GTK_MAJOR_VERSION) ||
-+ (gtk_minor_version != GTK_MINOR_VERSION) ||
-+ (gtk_micro_version != GTK_MICRO_VERSION))
-+ {
-+ printf("*** GTK+ header files (version %d.%d.%d) do not match\n",
-+ GTK_MAJOR_VERSION, GTK_MINOR_VERSION, GTK_MICRO_VERSION);
-+ printf("*** library (version %d.%d.%d)\n",
-+ gtk_major_version, gtk_minor_version, gtk_micro_version);
-+ }
-+ else
-+ {
-+ if ((gtk_major_version > major) ||
-+ ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
-+ ((gtk_major_version == major) && (gtk_minor_version == minor) && (gtk_micro_version >= micro)))
-+ {
-+ return 0;
-+ }
-+ else
-+ {
-+ printf("\n*** An old version of GTK+ (%d.%d.%d) was found.\n",
-+ gtk_major_version, gtk_minor_version, gtk_micro_version);
-+ printf("*** You need a version of GTK+ newer than %d.%d.%d. The latest version of\n",
-+ major, minor, micro);
-+ printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
-+ printf("***\n");
-+ printf("*** If you have already installed a sufficiently new version, this error\n");
-+ printf("*** probably means that the wrong copy of the pkg-config shell script is\n");
-+ printf("*** being found. The easiest way to fix this is to remove the old version\n");
-+ printf("*** of GTK+, but you can also set the PKG_CONFIG environment to point to the\n");
-+ printf("*** correct copy of pkg-config. (In this case, you will have to\n");
-+ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
-+ printf("*** so that the correct libraries are found at run-time))\n");
-+ }
-+ }
-+ return 1;
-+}
-+],, no_gtk=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
-+ CFLAGS="$ac_save_CFLAGS"
-+ LIBS="$ac_save_LIBS"
-+ fi
-+ fi
-+ if test "x$no_gtk" = x ; then
-+ AC_MSG_RESULT(yes (version $gtk_config_major_version.$gtk_config_minor_version.$gtk_config_micro_version))
-+ ifelse([$2], , :, [$2])
-+ else
-+ AC_MSG_RESULT(no)
-+ if test "$PKG_CONFIG" = "no" ; then
-+ echo "*** A new enough version of pkg-config was not found."
-+ echo "*** See http://pkgconfig.sourceforge.net"
-+ else
-+ if test -f conf.gtktest ; then
-+ :
-+ else
-+ echo "*** Could not run GTK+ test program, checking why..."
-+ ac_save_CFLAGS="$CFLAGS"
-+ ac_save_LIBS="$LIBS"
-+ CFLAGS="$CFLAGS $GTK_CFLAGS"
-+ LIBS="$LIBS $GTK_LIBS"
-+ AC_TRY_LINK([
-+#include <gtk/gtk.h>
-+#include <stdio.h>
-+], [ return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version)); ],
-+ [ echo "*** The test program compiled, but did not run. This usually means"
-+ echo "*** that the run-time linker is not finding GTK+ or finding the wrong"
-+ echo "*** version of GTK+. If it is not finding GTK+, you'll need to set your"
-+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
-+ echo "*** to the installed location Also, make sure you have run ldconfig if that"
-+ echo "*** is required on your system"
-+ echo "***"
-+ echo "*** If you have an old version installed, it is best to remove it, although"
-+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH" ],
-+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
-+ echo "*** exact error that occured. This usually means GTK+ is incorrectly installed."])
-+ CFLAGS="$ac_save_CFLAGS"
-+ LIBS="$ac_save_LIBS"
-+ fi
-+ fi
-+ GTK_CFLAGS=""
-+ GTK_LIBS=""
-+ ifelse([$3], , :, [$3])
-+ fi
-+ AC_SUBST(GTK_CFLAGS)
-+ AC_SUBST(GTK_LIBS)
-+ rm -f conf.gtktest
-+])
-+
-+# Configure paths for GTK+
-+# Owen Taylor 97-11-3
-+
-+dnl AM_PATH_GTK([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
-+dnl Test for GTK, and define GTK_CFLAGS and GTK_LIBS
-+dnl
-+AC_DEFUN(AM_PATH_GTK,
-+[dnl
-+dnl Get the cflags and libraries from the gtk-config script
-+dnl
-+AC_ARG_WITH(gtk-prefix,[ --with-gtk-prefix=PFX Prefix where GTK is installed (optional)],
-+ gtk_config_prefix="$withval", gtk_config_prefix="")
-+AC_ARG_WITH(gtk-exec-prefix,[ --with-gtk-exec-prefix=PFX Exec prefix where GTK is installed (optional)],
-+ gtk_config_exec_prefix="$withval", gtk_config_exec_prefix="")
-+AC_ARG_ENABLE(gtktest, [ --disable-gtktest Do not try to compile and run a test GTK program],
-+ , enable_gtktest=yes)
-+
-+ for module in . $4
-+ do
-+ case "$module" in
-+ gthread)
-+ gtk_config_args="$gtk_config_args gthread"
-+ ;;
-+ esac
-+ done
-+
-+ if test x$gtk_config_exec_prefix != x ; then
-+ gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
-+ if test x${GTK_CONFIG+set} != xset ; then
-+ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
-+ fi
-+ fi
-+ if test x$gtk_config_prefix != x ; then
-+ gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
-+ if test x${GTK_CONFIG+set} != xset ; then
-+ GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
-+ fi
-+ fi
-+
-+ AC_PATH_PROG(GTK_CONFIG, gtk-config, no)
-+ min_gtk_version=ifelse([$1], ,0.99.7,$1)
-+ AC_MSG_CHECKING(for GTK - version >= $min_gtk_version)
-+ no_gtk=""
-+ if test "$GTK_CONFIG" = "no" ; then
-+ no_gtk=yes
-+ else
-+ GTK_CFLAGS=`$GTK_CONFIG $gtk_config_args --cflags`
-+ GTK_LIBS=`$GTK_CONFIG $gtk_config_args --libs`
-+ gtk_config_major_version=`$GTK_CONFIG $gtk_config_args --version | \
-+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
-+ gtk_config_minor_version=`$GTK_CONFIG $gtk_config_args --version | \
-+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
-+ gtk_config_micro_version=`$GTK_CONFIG $gtk_config_args --version | \
-+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
-+ if test "x$enable_gtktest" = "xyes" ; then
-+ ac_save_CFLAGS="$CFLAGS"
-+ ac_save_LIBS="$LIBS"
-+ CFLAGS="$CFLAGS $GTK_CFLAGS"
-+ LIBS="$GTK_LIBS $LIBS"
-+dnl
-+dnl Now check if the installed GTK is sufficiently new. (Also sanity
-+dnl checks the results of gtk-config to some extent
-+dnl
-+ rm -f conf.gtktest
-+ AC_TRY_RUN([
-+#include <gtk/gtk.h>
-+#include <stdio.h>
-+#include <stdlib.h>
-+
-+int
-+main ()
-+{
-+ int major, minor, micro;
-+ char *tmp_version;
-+
-+ system ("touch conf.gtktest");
-+
-+ /* HP/UX 9 (%@#!) writes to sscanf strings */
-+ tmp_version = g_strdup("$min_gtk_version");
-+ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
-+ printf("%s, bad version string\n", "$min_gtk_version");
-+ exit(1);
-+ }
-+
-+ if ((gtk_major_version != $gtk_config_major_version) ||
-+ (gtk_minor_version != $gtk_config_minor_version) ||
-+ (gtk_micro_version != $gtk_config_micro_version))
-+ {
-+ printf("\n*** 'gtk-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
-+ $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
-+ gtk_major_version, gtk_minor_version, gtk_micro_version);
-+ printf ("*** was found! If gtk-config was correct, then it is best\n");
-+ printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
-+ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
-+ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
-+ printf("*** required on your system.\n");
-+ printf("*** If gtk-config was wrong, set the environment variable GTK_CONFIG\n");
-+ printf("*** to point to the correct copy of gtk-config, and remove the file config.cache\n");
-+ printf("*** before re-running configure\n");
-+ }
-+#if defined (GTK_MAJOR_VERSION) && defined (GTK_MINOR_VERSION) && defined (GTK_MICRO_VERSION)
-+ else if ((gtk_major_version != GTK_MAJOR_VERSION) ||
-+ (gtk_minor_version != GTK_MINOR_VERSION) ||
-+ (gtk_micro_version != GTK_MICRO_VERSION))
-+ {
-+ printf("*** GTK+ header files (version %d.%d.%d) do not match\n",
-+ GTK_MAJOR_VERSION, GTK_MINOR_VERSION, GTK_MICRO_VERSION);
-+ printf("*** library (version %d.%d.%d)\n",
-+ gtk_major_version, gtk_minor_version, gtk_micro_version);
-+ }
-+#endif /* defined (GTK_MAJOR_VERSION) ... */
-+ else
-+ {
-+ if ((gtk_major_version > major) ||
-+ ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
-+ ((gtk_major_version == major) && (gtk_minor_version == minor) && (gtk_micro_version >= micro)))
-+ {
-+ return 0;
-+ }
-+ else
-+ {
-+ printf("\n*** An old version of GTK+ (%d.%d.%d) was found.\n",
-+ gtk_major_version, gtk_minor_version, gtk_micro_version);
-+ printf("*** You need a version of GTK+ newer than %d.%d.%d. The latest version of\n",
-+ major, minor, micro);
-+ printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
-+ printf("***\n");
-+ printf("*** If you have already installed a sufficiently new version, this error\n");
-+ printf("*** probably means that the wrong copy of the gtk-config shell script is\n");
-+ printf("*** being found. The easiest way to fix this is to remove the old version\n");
-+ printf("*** of GTK+, but you can also set the GTK_CONFIG environment to point to the\n");
-+ printf("*** correct copy of gtk-config. (In this case, you will have to\n");
-+ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
-+ printf("*** so that the correct libraries are found at run-time))\n");
-+ }
-+ }
-+ return 1;
-+}
-+],, no_gtk=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
-+ CFLAGS="$ac_save_CFLAGS"
-+ LIBS="$ac_save_LIBS"
-+ fi
-+ fi
-+ if test "x$no_gtk" = x ; then
-+ AC_MSG_RESULT(yes)
-+ ifelse([$2], , :, [$2])
-+ else
-+ AC_MSG_RESULT(no)
-+ if test "$GTK_CONFIG" = "no" ; then
-+ echo "*** The gtk-config script installed by GTK could not be found"
-+ echo "*** If GTK was installed in PREFIX, make sure PREFIX/bin is in"
-+ echo "*** your path, or set the GTK_CONFIG environment variable to the"
-+ echo "*** full path to gtk-config."
-+ else
-+ if test -f conf.gtktest ; then
-+ :
-+ else
-+ echo "*** Could not run GTK test program, checking why..."
-+ CFLAGS="$CFLAGS $GTK_CFLAGS"
-+ LIBS="$LIBS $GTK_LIBS"
-+ AC_TRY_LINK([
-+#include <gtk/gtk.h>
-+#include <stdio.h>
-+], [ return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version)); ],
-+ [ echo "*** The test program compiled, but did not run. This usually means"
-+ echo "*** that the run-time linker is not finding GTK or finding the wrong"
-+ echo "*** version of GTK. If it is not finding GTK, you'll need to set your"
-+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
-+ echo "*** to the installed location Also, make sure you have run ldconfig if that"
-+ echo "*** is required on your system"
-+ echo "***"
-+ echo "*** If you have an old version installed, it is best to remove it, although"
-+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
-+ echo "***"
-+ echo "*** If you have a RedHat 5.0 system, you should remove the GTK package that"
-+ echo "*** came with the system with the command"
-+ echo "***"
-+ echo "*** rpm --erase --nodeps gtk gtk-devel" ],
-+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
-+ echo "*** exact error that occured. This usually means GTK was incorrectly installed"
-+ echo "*** or that you have moved GTK since it was installed. In the latter case, you"
-+ echo "*** may want to edit the gtk-config script: $GTK_CONFIG" ])
-+ CFLAGS="$ac_save_CFLAGS"
-+ LIBS="$ac_save_LIBS"
-+ fi
-+ fi
-+ GTK_CFLAGS=""
-+ GTK_LIBS=""
-+ ifelse([$3], , :, [$3])
-+ fi
-+ AC_SUBST(GTK_CFLAGS)
-+ AC_SUBST(GTK_LIBS)
-+ rm -f conf.gtktest
-+])
-+
diff --git a/net/mtr/files/patch-dns.c b/net/mtr/files/patch-dns.c
deleted file mode 100644
index c7bc30f1d9fb..000000000000
--- a/net/mtr/files/patch-dns.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- dns.c.orig Mon Oct 9 16:11:26 2006
-+++ dns.c Mon Oct 9 16:11:46 2006
-@@ -48,11 +48,13 @@
- #include "dns.h"
- #include "net.h"
-
-+/*
- #ifdef NO_STRERROR
- extern int sys_nerr;
- extern char *sys_errlist[];
- #define strerror(errno) (((errno) >= 0 && (errno) < sys_nerr) ? sys_errlist[errno] : "unlisted error")
- #endif
-+*/
-
- /* Hmm, it seems Irix requires this */
- extern int errno;