aboutsummaryrefslogtreecommitdiff
path: root/net/nast
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /net/nast
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
Notes
Diffstat (limited to 'net/nast')
-rw-r--r--net/nast/Makefile26
-rw-r--r--net/nast/files/patch-configure57
2 files changed, 67 insertions, 16 deletions
diff --git a/net/nast/Makefile b/net/nast/Makefile
index 23e1b799c308..9a384d2d86e1 100644
--- a/net/nast/Makefile
+++ b/net/nast/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nast
PORTVERSION= 0.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://download.berlios.de/${PORTNAME}/ \
http://voodoo.bawue.com/download/
@@ -16,33 +16,27 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Nast is a packet sniffer
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
-
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet-config
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
MAN8= nast.8
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
USE_GMAKE= yes
PLIST_FILES= bin/nast
-.include <bsd.port.pre.mk>
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} ""#######################################################
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You need ${PORTSDIR}/net/libnet-devel to build this port
- @${ECHO_MSG} ""
- @${ECHO_MSG} ""#######################################################
- @${ECHO_MSG} ""
+.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|CFLAGS="-Wall -O2 -pthread"||g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|CFLAGS="-Wall -O2 -pthread"||g; \
+ s|libnet-config|${LIBNET_CONFIG}|; \
+ s|-lnet|`${LIBNET_CONFIG} --libs`|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/net/nast/files/patch-configure b/net/nast/files/patch-configure
new file mode 100644
index 000000000000..a2fd431efbcb
--- /dev/null
+++ b/net/nast/files/patch-configure
@@ -0,0 +1,57 @@
+--- ./configure.orig Wed Sep 27 18:27:36 2006
++++ ./configure Wed Sep 27 19:04:20 2006
+@@ -2337,52 +2337,8 @@
+ #
+
+ filechk="yes"
+-echo "$as_me:$LINENO: checking for /usr/lib/libnet.a" >&5
+-echo $ECHO_N "checking for /usr/lib/libnet.a... $ECHO_C" >&6
+-if test "${ac_cv_file__usr_lib_libnet_a+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- test "$cross_compiling" = yes &&
+- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+- { (exit 1); exit 1; }; }
+-if test -r "/usr/lib/libnet.a"; then
+- ac_cv_file__usr_lib_libnet_a=yes
+-else
+- ac_cv_file__usr_lib_libnet_a=no
+-fi
+-fi
+-echo "$as_me:$LINENO: result: $ac_cv_file__usr_lib_libnet_a" >&5
+-echo "${ECHO_T}$ac_cv_file__usr_lib_libnet_a" >&6
+-if test $ac_cv_file__usr_lib_libnet_a = yes; then
+- :
+-else
+- filechk="no"
+-fi
+-
+-if test "$filechk" = "no"; then
+- echo "$as_me:$LINENO: checking for /usr/local/lib/libnet.a" >&5
+-echo $ECHO_N "checking for /usr/local/lib/libnet.a... $ECHO_C" >&6
+-if test "${ac_cv_file__usr_local_lib_libnet_a+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- test "$cross_compiling" = yes &&
+- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+- { (exit 1); exit 1; }; }
+-if test -r "/usr/local/lib/libnet.a"; then
+- ac_cv_file__usr_local_lib_libnet_a=yes
+-else
+- ac_cv_file__usr_local_lib_libnet_a=no
+-fi
+-fi
+-echo "$as_me:$LINENO: result: $ac_cv_file__usr_local_lib_libnet_a" >&5
+-echo "${ECHO_T}$ac_cv_file__usr_local_lib_libnet_a" >&6
+-if test $ac_cv_file__usr_local_lib_libnet_a = yes; then
+- filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include"
+-fi
+-
+-fi
++CPPFLAGS="`libnet-config --cflags`"
++LDFLAGS="`libnet-config --libs`"
+
+ if test "$filechk" = "no"; then { { echo "$as_me:$LINENO: error:
+