aboutsummaryrefslogtreecommitdiff
path: root/net/ncp
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-22 18:44:15 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-22 18:44:15 +0000
commitdd13b234ca6e6c99322cbd59f297607dff8074bf (patch)
treeaeda82002ae2af1cfc3404b120d81b4ca4e50be7 /net/ncp
parent08a2ffd85ea0142365c6ece4f4d21f4e12cc18a7 (diff)
downloadports-dd13b234ca6e6c99322cbd59f297607dff8074bf.tar.gz
ports-dd13b234ca6e6c99322cbd59f297607dff8074bf.zip
Notes
Diffstat (limited to 'net/ncp')
-rw-r--r--net/ncp/Makefile30
-rw-r--r--net/ncp/distinfo4
-rw-r--r--net/ncp/pkg-plist3
3 files changed, 22 insertions, 15 deletions
diff --git a/net/ncp/Makefile b/net/ncp/Makefile
index 905841b6ae84..f1d092ef7592 100644
--- a/net/ncp/Makefile
+++ b/net/ncp/Makefile
@@ -5,25 +5,35 @@
# $FreeBSD$
PORTNAME= ncp
-PORTVERSION= 1.2.3
+PORTVERSION= 1.2.4
CATEGORIES= net
-MASTER_SITES= ftp://ftp.fu-berlin.de/unix/network/ncp/
+MASTER_SITES= http://dl.fefe.de/ http://dl.mteege.de/fefe/
MAINTAINER= matthias@mteege.de
-COMMENT= "A fast file copy tool for LANs."
+COMMENT= A fast file copy tool for LANs
-MAN1= ncp.1 npush.1
-MANCOMPRESSED= no
+BUILD_DEPENDS= ${LOCALBASE}/lib/libowfat.a:${PORTSDIR}/devel/libowfat
-WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
USE_REINPLACE= yes
+USE_GETOPT_LONG=yes
+MANCOMPRESSED= no
+
+MAN1= ncp.1 npush.1
+PLIST_FILES= bin/ncp bin/npush bin/npoll
+
+CFLAGS+= -I${LOCALBASE}/include/libowfat -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
post-patch:
- @${REINPLACE_CMD} -e 's|gcc -O2|${CC} ${CFLAGS}|' \
- ${WRKSRC}/conf-cc
- @${REINPLACE_CMD} -e 's|gcc|${CC} ${LDFLAGS}|' \
- ${WRKSRC}/conf-ld
+ @${REINPLACE_CMD} -e 's|^CC=gcc|CC=${CC}|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|^CFLAGS=.*|CFLAGS=${CFLAGS}|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|^LDFLAGS=.*|LDFLAGS=${LDFLAGS}|' \
+ ${WRKSRC}/Makefile
do-install:
cd ${WRKSRC}; ${INSTALL_PROGRAM} ncp ${PREFIX}/bin
diff --git a/net/ncp/distinfo b/net/ncp/distinfo
index 6ad6a384e8d6..4482885fa900 100644
--- a/net/ncp/distinfo
+++ b/net/ncp/distinfo
@@ -1,2 +1,2 @@
-MD5 (ncp-1.2.3.tar.bz2) = 4486819b63f2493d788f4a516d660b74
-SIZE (ncp-1.2.3.tar.bz2) = 30864
+MD5 (ncp-1.2.4.tar.bz2) = 421c4855bd3148b7d0a4342942b4bf13
+SIZE (ncp-1.2.4.tar.bz2) = 6172
diff --git a/net/ncp/pkg-plist b/net/ncp/pkg-plist
deleted file mode 100644
index f8f86c567c97..000000000000
--- a/net/ncp/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/ncp
-bin/npush
-bin/npoll