aboutsummaryrefslogtreecommitdiff
path: root/net/ndisc6
diff options
context:
space:
mode:
authorOllivier Robert <roberto@FreeBSD.org>2011-04-21 09:39:58 +0000
committerOllivier Robert <roberto@FreeBSD.org>2011-04-21 09:39:58 +0000
commit20512a82e2c19f3e8ad663c9b290152309eb67cb (patch)
treefdd9f2d0ebdf09534228e4e008daa9c4684ea839 /net/ndisc6
parentbfc47e8d84fb375826b099582f7b1aa25ec5706d (diff)
downloadports-20512a82e2c19f3e8ad663c9b290152309eb67cb.tar.gz
ports-20512a82e2c19f3e8ad663c9b290152309eb67cb.zip
Update to latest 1.0.1 with rdnssd.
Used the last patch in 155992 edited to fix the WITHOUT_NLS issue. PR: ports/155992 Submitted by: Mikhail Tsatsenko <m.tsatsenko@gmail.com> (MAINTAINER)
Notes
Notes: svn path=/head/; revision=272989
Diffstat (limited to 'net/ndisc6')
-rw-r--r--net/ndisc6/Makefile15
-rw-r--r--net/ndisc6/distinfo4
-rw-r--r--net/ndisc6/files/patch-cpp-syntax26
-rw-r--r--net/ndisc6/files/patch-rthdr-fbsd415
-rw-r--r--net/ndisc6/pkg-plist6
5 files changed, 17 insertions, 49 deletions
diff --git a/net/ndisc6/Makefile b/net/ndisc6/Makefile
index f39eff8e2ca4..eb625af063b4 100644
--- a/net/ndisc6/Makefile
+++ b/net/ndisc6/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ndisc6
-PORTVERSION= 0.7.2
+PORTVERSION= 1.0.1
CATEGORIES= net ipv6
MASTER_SITES= http://www.remlab.net/files/ndisc6/archive/ \
http://people.via.ecp.fr/~rem/www.remlab.net/files/ndisc6/archive/
@@ -14,15 +14,22 @@ MASTER_SITES= http://www.remlab.net/files/ndisc6/archive/ \
MAINTAINER= m.tsatsenko@gmail.com
COMMENT= IPv6 network diagnostic tools
+LICENSE= GPLv2
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-suid-install
-MAN1= tcpspray6.1 addrinfo.1 dnssort.1
-MAN8= ndisc6.8 rdisc6.8 rltraceroute6.8
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+.else
+CONFIGURE_ARGS+=--disable-nls
+.endif
+
+MAN1= addr2name.1 dnssort.1 tcpspray.1
+MAN8= ndisc6.8 rdisc6.8 rdnssd.8 rltraceroute6.8
MLINKS= rltraceroute6.8 tcptraceroute6.8 \
rltraceroute6.8 tracert6.8 \
- addrinfo.1 nameinfo.1
+ addr2name.1 name2addr.1
PORTDOCS= AUTHORS NEWS README
diff --git a/net/ndisc6/distinfo b/net/ndisc6/distinfo
index 3ed44323da4b..81e97d4bc025 100644
--- a/net/ndisc6/distinfo
+++ b/net/ndisc6/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ndisc6-0.7.2.tar.bz2) = d3ded639dfc05cab3525a601534d56da1531f92bf05856d15fddcca6e0886ee2
-SIZE (ndisc6-0.7.2.tar.bz2) = 105343
+SHA256 (ndisc6-1.0.1.tar.bz2) = 1daf9e08783d85aebe1e564d6e83d5a3d57baa231de98cc0d621ce3f7a62efdd
+SIZE (ndisc6-1.0.1.tar.bz2) = 237621
diff --git a/net/ndisc6/files/patch-cpp-syntax b/net/ndisc6/files/patch-cpp-syntax
deleted file mode 100644
index 0cd4f0046219..000000000000
--- a/net/ndisc6/files/patch-cpp-syntax
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: src/inet6rth.h
-===================================================================
---- src/inet6rth.h (revision 345)
-+++ src/inet6rth.h (revision 347)
-@@ -75,7 +75,7 @@
- # define IPV6_RECVRTHDR 56
- # define IPV6_RTHDR 57
- # elif defined (__FreeBSD__) || defined (__FreeBSD_kernel__) \
-- defined (__NetBSD__) || defined (__NetBSD_kernel__)
-+ || defined (__NetBSD__) || defined (__NetBSD_kernel__)
- # define IPV6_RECVRTHDR 38
- # define IPV6_RTHDR 51
- # else
-Index: src/traceroute.c
-===================================================================
---- src/traceroute.c (revision 345)
-+++ src/traceroute.c (revision 347)
-@@ -54,7 +54,7 @@
- # if defined (__linux__)
- # define IPV6_TCLASS 67
- # elif defined (__FreeBSD__) || defined (__FreeBSD_kernel__) \
-- defined (__NetBSD__) || defined (__NetBSD_kernel__)
-+ || defined (__NetBSD__) || defined (__NetBSD_kernel__)
- # define IPV6_TCLASS 61
- # else
- # warning Traffic class support missing! Define IPV6_TCLASS!
diff --git a/net/ndisc6/files/patch-rthdr-fbsd4 b/net/ndisc6/files/patch-rthdr-fbsd4
deleted file mode 100644
index 8cc7209dd3b5..000000000000
--- a/net/ndisc6/files/patch-rthdr-fbsd4
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: src/inet6rth.h
-===================================================================
---- src/inet6rth.h (revision 347)
-+++ src/inet6rth.h (revision 348)
-@@ -26,6 +26,10 @@
- #include <sys/socket.h>
- #include <netinet/in.h>
-
-+#define inet6_rth_space working_inet6_rth_space
-+#define inet6_rth_init working_inet6_rth_init
-+#define inet6_rth_add working_inet6_rth_add
-+
- #ifndef IPV6_RTHDR_TYPE_0
- # define IPV6_RTHDR_TYPE_0 0
- #endif
diff --git a/net/ndisc6/pkg-plist b/net/ndisc6/pkg-plist
index 912d26a47ba8..421b746edfa2 100644
--- a/net/ndisc6/pkg-plist
+++ b/net/ndisc6/pkg-plist
@@ -1,9 +1,11 @@
-bin/addrinfo
+bin/addr2name
bin/dnssort
-bin/nameinfo
+bin/name2addr
+bin/tcpspray
bin/tcpspray6
sbin/ndisc6
sbin/rdisc6
+sbin/rdnssd
sbin/tcptraceroute6
sbin/rltraceroute6
sbin/tracert6