aboutsummaryrefslogtreecommitdiff
path: root/net/ndisc6
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-07-24 17:27:35 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-07-24 17:27:35 +0000
commitf224bc38cb0fd4b92eb47062ac7a42e29ee1e67f (patch)
treec21c98cf67920ce931a5c3da03cd3b698fbcb62d /net/ndisc6
parent3682dca767179ffe0261d716db283044aed88fe2 (diff)
downloadports-f224bc38cb0fd4b92eb47062ac7a42e29ee1e67f.tar.gz
ports-f224bc38cb0fd4b92eb47062ac7a42e29ee1e67f.zip
Notes
Diffstat (limited to 'net/ndisc6')
-rw-r--r--net/ndisc6/Makefile9
-rw-r--r--net/ndisc6/files/extra-patch-rdnssd-rdnssd.h18
2 files changed, 26 insertions, 1 deletions
diff --git a/net/ndisc6/Makefile b/net/ndisc6/Makefile
index f34cd1bf917f..ca3aa2a0e8dd 100644
--- a/net/ndisc6/Makefile
+++ b/net/ndisc6/Makefile
@@ -16,10 +16,17 @@ MAINTAINER= m.tsatsenko@gmail.com
COMMENT= IPv6 network diagnostic tools
LICENSE= GPLv2
+
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-suid-install
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 900000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-rdnssd-rdnssd.h
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
.else
@@ -43,4 +50,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/ndisc6/files/extra-patch-rdnssd-rdnssd.h b/net/ndisc6/files/extra-patch-rdnssd-rdnssd.h
new file mode 100644
index 000000000000..1aa03c3104b9
--- /dev/null
+++ b/net/ndisc6/files/extra-patch-rdnssd-rdnssd.h
@@ -0,0 +1,18 @@
+--- rdnssd/rdnssd.h.orig 2011-07-23 01:03:38.000000000 +0400
++++ rdnssd/rdnssd.h 2011-07-23 01:03:56.000000000 +0400
+@@ -32,15 +32,6 @@
+ /* Belongs in <netinet/icmp6.h> */
+ #define ND_OPT_RDNSS 25
+
+-struct nd_opt_rdnss
+-{
+- uint8_t nd_opt_rdnss_type;
+- uint8_t nd_opt_rdnss_len;
+- uint16_t nd_opt_rdnss_resserved1;
+- uint32_t nd_opt_rdnss_lifetime;
+- /* followed by one or more IPv6 addresses */
+-};
+-
+ # ifdef __cplusplus
+ extern "C" {
+ # endif