aboutsummaryrefslogtreecommitdiff
path: root/net/ndpi/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-02 08:02:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-02 08:02:31 +0000
commit65500ed125c2efe788d2f83ef57838f285acf68c (patch)
treea35f5a8eef584a275d7b109b3d7b0f71076c61c2 /net/ndpi/Makefile
parent5034f925da1b45e57d55c7d218fc160d1441dffc (diff)
downloadports-65500ed125c2efe788d2f83ef57838f285acf68c.tar.gz
ports-65500ed125c2efe788d2f83ef57838f285acf68c.zip
Notes
Diffstat (limited to 'net/ndpi/Makefile')
-rw-r--r--net/ndpi/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net/ndpi/Makefile b/net/ndpi/Makefile
new file mode 100644
index 000000000000..0b26cb99ab8a
--- /dev/null
+++ b/net/ndpi/Makefile
@@ -0,0 +1,22 @@
+# Created by: Muhammad Moinur Rahman <5u623l20@gmail.com>
+# $FreeBSD$
+
+PORTNAME= ndpi
+PORTVERSION= 1.4.0
+CATEGORIES= net
+MASTER_SITES= SF/ntop/nDPI
+DISTNAME= nDPI-${PORTVERSION}_r7023
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= ntop-maintained superset of the popular OpenDPI library
+
+LICENSE= GPLv3
+
+CONFIGURE_ARGS= --with-pic
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= pathfix pkgconfig
+
+PLIST_SUB= MAJOR_VER=${PORTVERSION:R}
+
+.include <bsd.port.mk>