aboutsummaryrefslogtreecommitdiff
path: root/net/ndpi/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-08-20 20:14:54 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-08-20 20:14:54 +0000
commit7ae164d45112ff57de639ead38dd52a73efd71ab (patch)
tree39e8f70a1964f187196a0f689750b746ecb8dec2 /net/ndpi/Makefile
parent582199510db502c680d3538a1b0112f3e6f2009a (diff)
downloadports-7ae164d45112ff57de639ead38dd52a73efd71ab.tar.gz
ports-7ae164d45112ff57de639ead38dd52a73efd71ab.zip
Notes
Diffstat (limited to 'net/ndpi/Makefile')
-rw-r--r--net/ndpi/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/net/ndpi/Makefile b/net/ndpi/Makefile
index b092a2584420..bbb2625c16dc 100644
--- a/net/ndpi/Makefile
+++ b/net/ndpi/Makefile
@@ -2,22 +2,30 @@
# $FreeBSD$
PORTNAME= ndpi
-PORTVERSION= 1.4.0
-PORTREVISION= 1
+PORTVERSION= 1.5.0
CATEGORIES= net
MASTER_SITES= SF/ntop/nDPI
-DISTNAME= nDPI-${PORTVERSION}_r7023
+DISTNAME= libndpi-${PORTVERSION}_r8115
MAINTAINER= 5u623l20@gmail.com
-COMMENT= ntop-maintained superset of the popular OpenDPI library
+COMMENT= NTOP-maintained superset of the popular OpenDPI library
LICENSE= GPLv3
+LIB_DEPENDS= libjson-c.so:${PORTSDIR}/devel/json-c
+
CONFIGURE_ARGS= --with-pic
+CPPFLAGS+= -I${LOCALBASE}/include/json-c
+LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -ljson-c
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= libtool pathfix pkgconfig
+USES= libtool pathfix pkgconfig compiler:c++11-lang
+WRKSRC= ${WRKDIR}/libndpi-${PORTVERSION}
+
+PLIST_SUB= MAJOR_VER=${PORTVERSION}
-PLIST_SUB= MAJOR_VER=${PORTVERSION:R}
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libndpi.so.1.0.0
.include <bsd.port.mk>