aboutsummaryrefslogtreecommitdiff
path: root/net/ndpi/files/patch-autogen.sh
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2017-12-09 17:11:09 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2017-12-09 17:11:09 +0000
commit13bb6f87c0029521142150baf5a28b3cd58fea6a (patch)
treed11ada346efd08ad51f5e6b3d9ef8c37dea4d105 /net/ndpi/files/patch-autogen.sh
parent881aa7cedb1684f35387f9835abd961ebb417b01 (diff)
downloadports-13bb6f87c0029521142150baf5a28b3cd58fea6a.tar.gz
ports-13bb6f87c0029521142150baf5a28b3cd58fea6a.zip
Notes
Diffstat (limited to 'net/ndpi/files/patch-autogen.sh')
-rw-r--r--net/ndpi/files/patch-autogen.sh37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/ndpi/files/patch-autogen.sh b/net/ndpi/files/patch-autogen.sh
new file mode 100644
index 000000000000..8de12e2b9764
--- /dev/null
+++ b/net/ndpi/files/patch-autogen.sh
@@ -0,0 +1,37 @@
+--- autogen.sh.orig 2017-12-03 18:07:29 UTC
++++ autogen.sh
+@@ -5,34 +5,4 @@ NDPI_MINOR="2"
+ NDPI_PATCH="0"
+ NDPI_VERSION_SHORT="$NDPI_MAJOR.$NDPI_MINOR.$NDPI_PATCH"
+
+-/bin/rm -f configure config.h config.h.in src/lib/Makefile.in
+-
+-AUTOCONF=$(which autoconf)
+-AUTOMAKE=$(which automake)
+-LIBTOOL=$(which libtool)
+-LIBTOOLIZE=$(which libtoolize)
+-AUTORECONF=$(which autoreconf)
+-
+-if test -z $AUTOCONF; then
+- echo "autoconf is missing: please install it and try again"
+- exit
+-fi
+-
+-if test -z $AUTOMAKE; then
+- echo "automake is missing: please install it and try again"
+- exit
+-fi
+-
+-if test -z $LIBTOOL && test -z $LIBTOOLIZE ; then
+- echo "libtool and libtoolize is missing: please install it and try again"
+- exit
+-fi
+-
+-if test -z $AUTORECONF; then
+- echo "autoreconf is missing: please install it and try again"
+- exit
+-fi
+-
+ cat configure.seed | sed "s/@NDPI_MAJOR@/$NDPI_MAJOR/g" | sed "s/@NDPI_MINOR@/$NDPI_MINOR/g" | sed "s/@NDPI_PATCH@/$NDPI_PATCH/g" | sed "s/@NDPI_VERSION_SHORT@/$NDPI_VERSION_SHORT/g" > configure.ac
+-autoreconf -ivf
+-./configure $*