aboutsummaryrefslogtreecommitdiff
path: root/net/nemesis/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /net/nemesis/Makefile
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
Notes
Diffstat (limited to 'net/nemesis/Makefile')
-rw-r--r--net/nemesis/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/nemesis/Makefile b/net/nemesis/Makefile
index 30d67a8cda47..b34ccf3cf42e 100644
--- a/net/nemesis/Makefile
+++ b/net/nemesis/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nemesis
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= molter@tin.it
COMMENT= Command-line network packet creation and injection suite
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libnet-includes="${LOCALBASE}/include" \
@@ -27,4 +27,10 @@ MAN1= nemesis-arp.1 nemesis-dns.1 nemesis-ethernet.1 nemesis-icmp.1 \
nemesis-tcp.1 nemesis-udp.1 nemesis.1
PLIST_FILES= bin/nemesis
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
.include <bsd.port.mk>