aboutsummaryrefslogtreecommitdiff
path: root/net/nemesis
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-07-01 17:39:00 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-07-01 17:39:00 +0000
commit1f94eebf99e29414292c3aa9c2bdffb934926f56 (patch)
tree196d5e0a03768753150490c68e4af77918220630 /net/nemesis
parent30f68fa24bb05a011cf022c0990b680680dba944 (diff)
downloadports-1f94eebf99e29414292c3aa9c2bdffb934926f56.tar.gz
ports-1f94eebf99e29414292c3aa9c2bdffb934926f56.zip
Notes
Diffstat (limited to 'net/nemesis')
-rw-r--r--net/nemesis/Makefile11
-rw-r--r--net/nemesis/distinfo2
-rw-r--r--net/nemesis/files/patch-aa52
-rw-r--r--net/nemesis/pkg-descr36
-rw-r--r--net/nemesis/pkg-plist9
5 files changed, 22 insertions, 88 deletions
diff --git a/net/nemesis/Makefile b/net/nemesis/Makefile
index 14718c866db3..b8f608690b64 100644
--- a/net/nemesis/Makefile
+++ b/net/nemesis/Makefile
@@ -6,9 +6,11 @@
#
PORTNAME= nemesis
-PORTVERSION= 1.32
+PORTVERSION= 1.4.b3
+PORTEPOCH= 1
CATEGORIES= net security
-MASTER_SITES= http://jeff.wwti.com/nemesis/
+MASTER_SITES= http://www.packetfactory.net/projects/nemesis/
+DISTNAME= nemesis-1.4beta3
MAINTAINER= molter@tin.it
COMMENT= Command-line UNIX network packet creation and injection suite
@@ -20,7 +22,8 @@ CONFIGURE_ENV= CCOPTS="${CFLAGS}" \
CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
-MAN1= nemesis-arp.1 nemesis-dns.1 nemesis-icmp.1 nemesis-igmp.1 \
- nemesis-ospf.1 nemesis-rip.1 nemesis-tcp.1 nemesis-udp.1
+MAN1= nemesis-arp.1 nemesis-dns.1 nemesis-ethernet.1 nemesis-icmp.1 \
+ nemesis-igmp.1 nemesis-ip.1 nemesis-ospf.1 nemesis-rip.1 \
+ nemesis-tcp.1 nemesis-udp.1 nemesis.1
.include <bsd.port.mk>
diff --git a/net/nemesis/distinfo b/net/nemesis/distinfo
index f13296ba1986..1b07a0b027a4 100644
--- a/net/nemesis/distinfo
+++ b/net/nemesis/distinfo
@@ -1 +1 @@
-MD5 (nemesis-1.32.tar.gz) = 19e3e8eb6ff86c35580adf630e6df398
+MD5 (nemesis-1.4beta3.tar.gz) = 6409bddf2d54cc9400028f491d342aea
diff --git a/net/nemesis/files/patch-aa b/net/nemesis/files/patch-aa
deleted file mode 100644
index 8a43125610e6..000000000000
--- a/net/nemesis/files/patch-aa
+++ /dev/null
@@ -1,52 +0,0 @@
---- Makefile.in.orig Sun Dec 31 10:49:50 2000
-+++ Makefile.in Thu Jan 25 20:31:53 2001
-@@ -34,6 +34,8 @@
- UDP_MAN = nemesis-udp.1
-
- INSTALL = @INSTALL@
-+INSTALL_PROGRAM = @INSTALL_PROGRAM@
-+INSTALL_DATA = @INSTALL_DATA@
-
- # Compiler
- #
-@@ -84,23 +86,23 @@
- strip $(TCP_TARGET)
- strip $(UDP_TARGET)
-
--install: nemesis strip
-- $(INSTALL) -c -m 0755 $(ARP_TARGET) $(DESTDIR)$(prefix)/sbin
-- $(INSTALL) -c -m 0755 $(DNS_TARGET) $(DESTDIR)$(prefix)/sbin
-- $(INSTALL) -c -m 0755 $(ICMP_TARGET) $(DESTDIR)$(prefix)/sbin
-- $(INSTALL) -c -m 0755 $(IGMP_TARGET) $(DESTDIR)$(prefix)/sbin
-- $(INSTALL) -c -m 0755 $(OSPF_TARGET) $(DESTDIR)$(prefix)/sbin
-- $(INSTALL) -c -m 0755 $(RIP_TARGET) $(DESTDIR)$(prefix)/sbin
-- $(INSTALL) -c -m 0755 $(TCP_TARGET) $(DESTDIR)$(prefix)/sbin
-- $(INSTALL) -c -m 0755 $(UDP_TARGET) $(DESTDIR)$(prefix)/sbin
-- $(INSTALL) -c -m 0644 $(ARP_MAN) $(DESTDIR)$(prefix)/man/man1
-- $(INSTALL) -c -m 0644 $(DNS_MAN) $(DESTDIR)$(prefix)/man/man1
-- $(INSTALL) -c -m 0644 $(ICMP_MAN) $(DESTDIR)$(prefix)/man/man1
-- $(INSTALL) -c -m 0644 $(IGMP_MAN) $(DESTDIR)$(prefix)/man/man1
-- $(INSTALL) -c -m 0644 $(OSPF_MAN) $(DESTDIR)$(prefix)/man/man1
-- $(INSTALL) -c -m 0644 $(RIP_MAN) $(DESTDIR)$(prefix)/man/man1
-- $(INSTALL) -c -m 0644 $(TCP_MAN) $(DESTDIR)$(prefix)/man/man1
-- $(INSTALL) -c -m 0644 $(UDP_MAN) $(DESTDIR)$(prefix)/man/man1
-+install: all
-+ $(INSTALL_PROGRAM) $(ARP_TARGET) $(DESTDIR)$(prefix)/sbin
-+ $(INSTALL_PROGRAM) $(DNS_TARGET) $(DESTDIR)$(prefix)/sbin
-+ $(INSTALL_PROGRAM) $(ICMP_TARGET) $(DESTDIR)$(prefix)/sbin
-+ $(INSTALL_PROGRAM) $(IGMP_TARGET) $(DESTDIR)$(prefix)/sbin
-+ $(INSTALL_PROGRAM) $(OSPF_TARGET) $(DESTDIR)$(prefix)/sbin
-+ $(INSTALL_PROGRAM) $(RIP_TARGET) $(DESTDIR)$(prefix)/sbin
-+ $(INSTALL_PROGRAM) $(TCP_TARGET) $(DESTDIR)$(prefix)/sbin
-+ $(INSTALL_PROGRAM) $(UDP_TARGET) $(DESTDIR)$(prefix)/sbin
-+ $(INSTALL_DATA) $(ARP_MAN) $(DESTDIR)$(prefix)/man/man1
-+ $(INSTALL_DATA) $(DNS_MAN) $(DESTDIR)$(prefix)/man/man1
-+ $(INSTALL_DATA) $(ICMP_MAN) $(DESTDIR)$(prefix)/man/man1
-+ $(INSTALL_DATA) $(IGMP_MAN) $(DESTDIR)$(prefix)/man/man1
-+ $(INSTALL_DATA) $(OSPF_MAN) $(DESTDIR)$(prefix)/man/man1
-+ $(INSTALL_DATA) $(RIP_MAN) $(DESTDIR)$(prefix)/man/man1
-+ $(INSTALL_DATA) $(TCP_MAN) $(DESTDIR)$(prefix)/man/man1
-+ $(INSTALL_DATA) $(UDP_MAN) $(DESTDIR)$(prefix)/man/man1
-
- clean:
- rm -f core *.core *.o $(ARP_TARGET) $(DNS_TARGET) \
diff --git a/net/nemesis/pkg-descr b/net/nemesis/pkg-descr
index 34bf888a26fc..56c87daa36df 100644
--- a/net/nemesis/pkg-descr
+++ b/net/nemesis/pkg-descr
@@ -1,31 +1,21 @@
-The Nemesis Project is designed to be a commandline-based, portable human IP
-stack for UNIX/Linux. The suite is broken down by protocol, and should allow
-for useful scripting of injected packet streams from simple shell scripts.
+The Nemesis Project is designed to be a command line based, portable human IP
+stack for UNIX-like and Windows sytems. The suite is broken down by protocol,
+and should allow for useful scripting of injected packets from simple shell
+scripts.
Key Features:
-+ ARP/RARP, DNS, ICMP, IGMP, OSPF, RIP, TCP, UDP protocol support
++ ARP/RARP, DNS, ETHERNET, ICMP, IGMP, IP, OSPF*, RIP, TCP, UDP protocol support
+ Layer 2 or Layer 3 injection (by presence/absence of -d <dev> switch)
-+ Packet Payload from file
-+ tested on OpenBSD, NetBSD, FreeBSD, Solaris/Trusted Solaris, Linux,
- and Mac OS X
+ on UNIX-like systems.
++ Layer 2 injection on Windows systems (regardless of whether
+ -d <device number> is used.
++ Packet payload from file
++ IP and TCP options from file
++ Tested on OpenBSD, Linux, Solaris, Mac OS X and Windows 2000
-Example usage:
+Each supported protocol uses its own protocol "injector" which is accompanied
+by a man page explaning its functionality.
-* nemesis-tcp -v -S 192.168.1.1 -D 192.168.2.2 -fS -fA -y 22 -P foo
- send TCP packet (SYN/ACK) with payload from ascii file 'foo' to target's
- ssh port from 192.168.1.1 to 192.168.2.2. (-v allows a stdout visual of
- current injected packet)
-
-* nemesis-icmp -S 10.10.10.3 -D 10.10.10.1 -G 10.10.10.3 -i 5
- send ICMP REDIRECT (network) packet from 10.10.10.3 to 10.10.10.1
- with preferred gateway as source address.
-
-* nemesis-arp -v -d ne0 -H 0:1:2:3:4:5 -S 10.11.30.5 -D 10.10.15.1
- send ARP packet through device 'ne0' from hardware source address
- 00:01:02:03:04:05 with IP source address 10.11.30.5 to destination IP
- address 10.10.15.1 with broadcast destination hardware address.
- In other words, who-has the mac address of 10.10.15.1, tell 10.11.30.5
- - assuming 00:01:02:03:04:05 is the source mac address of our 'ne0' device.
WWW: http://www.packetfactory.net/projects/nemesis/
diff --git a/net/nemesis/pkg-plist b/net/nemesis/pkg-plist
index fd6b1f2b21f0..774f686ae3d9 100644
--- a/net/nemesis/pkg-plist
+++ b/net/nemesis/pkg-plist
@@ -1,9 +1,2 @@
@comment $FreeBSD$
-sbin/nemesis-arp
-sbin/nemesis-dns
-sbin/nemesis-icmp
-sbin/nemesis-igmp
-sbin/nemesis-ospf
-sbin/nemesis-rip
-sbin/nemesis-tcp
-sbin/nemesis-udp
+bin/nemesis