aboutsummaryrefslogtreecommitdiff
path: root/net/nemesis
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2005-04-02 22:34:30 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2005-04-02 22:34:30 +0000
commitdce30f5fba1186265419a299f3c1a153747c1c9e (patch)
treef01f8570cfc73e4d74d6ae169b597faf28b8e8b1 /net/nemesis
parent8f4433d3b7f19a9e7820104bc8815a7879d0ad48 (diff)
downloadports-dce30f5fba1186265419a299f3c1a153747c1c9e.tar.gz
ports-dce30f5fba1186265419a299f3c1a153747c1c9e.zip
Notes
Diffstat (limited to 'net/nemesis')
-rw-r--r--net/nemesis/Makefile14
-rw-r--r--net/nemesis/distinfo4
-rw-r--r--net/nemesis/files/patch-configure13
-rw-r--r--net/nemesis/pkg-descr8
-rw-r--r--net/nemesis/pkg-plist2
5 files changed, 25 insertions, 16 deletions
diff --git a/net/nemesis/Makefile b/net/nemesis/Makefile
index b8f608690b64..1919d73230ce 100644
--- a/net/nemesis/Makefile
+++ b/net/nemesis/Makefile
@@ -6,24 +6,24 @@
#
PORTNAME= nemesis
-PORTVERSION= 1.4.b3
+PORTVERSION= 1.4
PORTEPOCH= 1
CATEGORIES= net security
-MASTER_SITES= http://www.packetfactory.net/projects/nemesis/
-DISTNAME= nemesis-1.4beta3
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= molter@tin.it
-COMMENT= Command-line UNIX network packet creation and injection suite
+COMMENT= Command-line network packet creation and injection suite
BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CCOPTS="${CFLAGS}" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib" \
+CONFIGURE_ARGS= --with-libnet-includes="${LOCALBASE}/include" \
+ --with-libnet-libraries="${LOCALBASE}/lib"
MAN1= nemesis-arp.1 nemesis-dns.1 nemesis-ethernet.1 nemesis-icmp.1 \
nemesis-igmp.1 nemesis-ip.1 nemesis-ospf.1 nemesis-rip.1 \
nemesis-tcp.1 nemesis-udp.1 nemesis.1
+PLIST_FILES= bin/nemesis
.include <bsd.port.mk>
diff --git a/net/nemesis/distinfo b/net/nemesis/distinfo
index 11f2077ad0e5..865f7189fce9 100644
--- a/net/nemesis/distinfo
+++ b/net/nemesis/distinfo
@@ -1,2 +1,2 @@
-MD5 (nemesis-1.4beta3.tar.gz) = 6409bddf2d54cc9400028f491d342aea
-SIZE (nemesis-1.4beta3.tar.gz) = 121017
+MD5 (nemesis-1.4.tar.gz) = acd7de57798a7f90f445f80d4d4a6e61
+SIZE (nemesis-1.4.tar.gz) = 144187
diff --git a/net/nemesis/files/patch-configure b/net/nemesis/files/patch-configure
new file mode 100644
index 000000000000..8fa8f4bb772b
--- /dev/null
+++ b/net/nemesis/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure.orig
++++ configure
+@@ -4148,7 +4148,6 @@
+
+
+ CPPFLAGS="${CPPFLAGS} `libnet-config --defines`"
+-CFLAGS="${CFLAGS} -funroll-loops -pipe"
+
+ if test `libnet-config --cflags | wc -c` = "1"; then
+ CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/sw/include"
diff --git a/net/nemesis/pkg-descr b/net/nemesis/pkg-descr
index 56c87daa36df..c8872d171766 100644
--- a/net/nemesis/pkg-descr
+++ b/net/nemesis/pkg-descr
@@ -1,7 +1,6 @@
The Nemesis Project is designed to be a command line based, portable human IP
-stack for UNIX-like and Windows sytems. The suite is broken down by protocol,
-and should allow for useful scripting of injected packets from simple shell
-scripts.
+stack. The suite is broken down by protocol, and should allow for useful
+scripting of injected packets from simple shell scripts.
Key Features:
@@ -12,10 +11,9 @@ Key Features:
-d <device number> is used.
+ Packet payload from file
+ IP and TCP options from file
-+ Tested on OpenBSD, Linux, Solaris, Mac OS X and Windows 2000
Each supported protocol uses its own protocol "injector" which is accompanied
by a man page explaning its functionality.
-WWW: http://www.packetfactory.net/projects/nemesis/
+WWW: http://nemesis.sourceforge.net/
diff --git a/net/nemesis/pkg-plist b/net/nemesis/pkg-plist
deleted file mode 100644
index 774f686ae3d9..000000000000
--- a/net/nemesis/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-@comment $FreeBSD$
-bin/nemesis