aboutsummaryrefslogtreecommitdiff
path: root/net/nepenthes
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-12-13 12:41:35 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-12-13 12:41:35 +0000
commit64e068d25c1370f67d2f0d779ac1719f9bc5d137 (patch)
treee8e79d2b112a29862848aa733e4b3f9387c78d2e /net/nepenthes
parent68ee2dd59c7dc7173d1688b825cc1c5a70f097c1 (diff)
downloadports-64e068d25c1370f67d2f0d779ac1719f9bc5d137.tar.gz
ports-64e068d25c1370f67d2f0d779ac1719f9bc5d137.zip
Notes
Diffstat (limited to 'net/nepenthes')
-rw-r--r--net/nepenthes/Makefile4
-rw-r--r--net/nepenthes/files/patch-modules-download-curl-download-curl.cpp12
2 files changed, 14 insertions, 2 deletions
diff --git a/net/nepenthes/Makefile b/net/nepenthes/Makefile
index decdc3339549..e27ff3756f7a 100644
--- a/net/nepenthes/Makefile
+++ b/net/nepenthes/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nepenthes
PORTVERSION= 0.1.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= nepenthes
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= nepenthes
MAINTAINER= systemoperator@gmail.com
COMMENT= Determine the malware activity on a network
-LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
magic.1:${PORTSDIR}/sysutils/file \
pcre.0:${PORTSDIR}/devel/pcre \
adns.1:${PORTSDIR}/dns/adns
diff --git a/net/nepenthes/files/patch-modules-download-curl-download-curl.cpp b/net/nepenthes/files/patch-modules-download-curl-download-curl.cpp
new file mode 100644
index 000000000000..5e0c0a4d1969
--- /dev/null
+++ b/net/nepenthes/files/patch-modules-download-curl-download-curl.cpp
@@ -0,0 +1,12 @@
+--- modules/download-curl/download-curl.cpp.orig Tue Dec 5 15:53:24 2006
++++ modules/download-curl/download-curl.cpp Tue Dec 5 15:54:09 2006
+@@ -230,7 +230,9 @@
+ down->getDownloadUrl()->getPort(),
+ down->getDownloadUrl()->getPath().c_str());
+ // string auth = down->getDownloadUrl()->getUser() + ":" + down->getDownloadUrl()->getPass();
++#if LIBCURL_VERSION_NUM < 0x071000
+ curl_easy_setopt(pCurlHandle, CURLOPT_SOURCE_USERPWD,(char *)down->getDownloadUrl()->getAuth().c_str());
++#endif
+ curl_easy_setopt(pCurlHandle, CURLOPT_USERPWD,(char *)down->getDownloadUrl()->getAuth().c_str());
+ curl_easy_setopt(pCurlHandle, CURLOPT_URL , url);
+ curl_easy_setopt(pCurlHandle, CURLOPT_FTP_RESPONSE_TIMEOUT, 120); // 2 min ftp timeout