aboutsummaryrefslogtreecommitdiff
path: root/net/net6/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
commit9346b215f04cc84bbb7125ff2fcf03978f859a21 (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /net/net6/Makefile
parent49ac3accb4fc378c681317849f4ae94655a61423 (diff)
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Notes
Notes: svn path=/head/; revision=301539
Diffstat (limited to 'net/net6/Makefile')
-rw-r--r--net/net6/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/net6/Makefile b/net/net6/Makefile
index bdac2d27b167..544cbce56c6e 100644
--- a/net/net6/Makefile
+++ b/net/net6/Makefile
@@ -15,7 +15,6 @@ COMMENT= Network access framework for IPv4/IPv6
LICENSE= GPLv2
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
gnutls.47:${PORTSDIR}/security/gnutls
@@ -23,6 +22,7 @@ USE_GNOME= gnomehack
USE_AUTOTOOLS= libtool
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls