aboutsummaryrefslogtreecommitdiff
path: root/net/net6/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-08 18:01:20 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-08 18:01:20 +0000
commitee955d916feb48f8c0a728943e0009c813dc4ac7 (patch)
tree0f984e55d1c6153047678c1413f73b2cf47dbf61 /net/net6/Makefile
parenta1e0fc3a966f0b47055f7996f662457839e289d9 (diff)
- Use new LIB_DEPENDS syntax
- Use OPTIONS_HELPERS The PR also included a fix for build with clang but this got already fixed PR: ports/185517 Submitted by: KATO Tsuguru
Notes
Notes: svn path=/head/; revision=339160
Diffstat (limited to 'net/net6/Makefile')
-rw-r--r--net/net6/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/net/net6/Makefile b/net/net6/Makefile
index 5384123a66e5..786bf83d46d5 100644
--- a/net/net6/Makefile
+++ b/net/net6/Makefile
@@ -12,23 +12,19 @@ COMMENT= Network access framework for IPv4/IPv6
LICENSE= GPLv2
-LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
- gnutls.26:${PORTSDIR}/security/gnutls
+LIB_DEPENDS= libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
+ libgnutls.so:${PORTSDIR}/security/gnutls
USES= pathfix pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+NLS_CPPFLAGS= -I${LOCALBASE}/include
+NLS_LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.mk>