aboutsummaryrefslogtreecommitdiff
path: root/net/net6
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-01-06 15:34:53 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-01-06 15:34:53 +0000
commitcda0880bf53251b679e1506fe4fa35c04d9c3b14 (patch)
tree81e819f7a0f21b65b549b2866777834e96c4ed83 /net/net6
parent488eff603e819b80cf488b1394d21cfbd2bd9d99 (diff)
downloadports-cda0880bf53251b679e1506fe4fa35c04d9c3b14.tar.gz
ports-cda0880bf53251b679e1506fe4fa35c04d9c3b14.zip
Notes
Diffstat (limited to 'net/net6')
-rw-r--r--net/net6/Makefile3
-rw-r--r--net/net6/files/patch-inc__address.hpp14
2 files changed, 15 insertions, 2 deletions
diff --git a/net/net6/Makefile b/net/net6/Makefile
index 8b9c740aa626..5384123a66e5 100644
--- a/net/net6/Makefile
+++ b/net/net6/Makefile
@@ -15,11 +15,10 @@ LICENSE= GPLv2
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
gnutls.26:${PORTSDIR}/security/gnutls
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/net/net6/files/patch-inc__address.hpp b/net/net6/files/patch-inc__address.hpp
new file mode 100644
index 000000000000..e3131760a675
--- /dev/null
+++ b/net/net6/files/patch-inc__address.hpp
@@ -0,0 +1,14 @@
+--- inc/address.hpp.orig 2011-09-10 17:59:50.000000000 +0300
++++ inc/address.hpp 2014-01-06 17:32:36.000000000 +0200
+@@ -25,9 +25,10 @@
+ #include <winsock2.h>
+ #include <ws2tcpip.h>
+ #else
++#include <sys/types.h>
+ #include <sys/socket.h>
+-#include <netinet/in_systm.h>
+ #include <netinet/in.h>
++#include <netinet/in_systm.h>
+ #include <netinet/ip.h>
+ #endif
+