aboutsummaryrefslogtreecommitdiff
path: root/net/netembryo/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-07-10 09:51:56 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-07-10 09:51:56 +0000
commit439fdbf09f5dc20eb5a4cb1ee7c4c2bb8c6e8949 (patch)
tree8004b70a453851e4581df3ae5594b3e1472d0337 /net/netembryo/Makefile
parent923a55a4eb7f0e70f0f8e923c77401cbda84e448 (diff)
downloadports-439fdbf09f5dc20eb5a4cb1ee7c4c2bb8c6e8949.tar.gz
ports-439fdbf09f5dc20eb5a4cb1ee7c4c2bb8c6e8949.zip
Notes
Diffstat (limited to 'net/netembryo/Makefile')
-rw-r--r--net/netembryo/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/net/netembryo/Makefile b/net/netembryo/Makefile
index c0e325583a57..3e032e60ca2f 100644
--- a/net/netembryo/Makefile
+++ b/net/netembryo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= netembryo
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://pkgs.fedoraproject.org/repo/pkgs/netembryo/netembryo-0.1.1.tar.bz2/d5a3c96b37fe3e4fb1c49df1f7a4a16f/ \
@@ -10,19 +11,19 @@ MASTER_SITES= ${MASTER_SITE_LOCAL} \
MASTER_SITE_SUBDIR= rakuco
MAINTAINER= ports@FreeBSD.org
-COMMENT= Network abstraction library used by for feng, libnemesi, felix
+COMMENT= Network abstraction library
LICENSE= LGPL21
OPTIONS_DEFINE= OPENSSL
OPTIONS_DEFAULT=OPENSSL
-USE_BZIP2= yes
-USES= pathfix pkgconfig gmake
+USES= gmake libtool pathfix pkgconfig tar:bzip2
USE_GNOME= glib20
-USE_AUTOTOOLS= libtool
-CONFIGURE_ARGS= --disable-silent-rules
USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-silent-rules
+INSTALL_TARGET= install-strip
.include <bsd.port.options.mk>
@@ -35,8 +36,6 @@ CONFIGURE_ARGS+=--without-openssl
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- 's|^CPPFLAGS=|#CPPFLAGS| ; \
- s|freebsd[0-9]|freebsd|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} '/_XOPEN_SOURCE/d' ${WRKSRC}/configure
.include <bsd.port.mk>