aboutsummaryrefslogtreecommitdiff
path: root/net/netembryo
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2007-12-18 01:53:16 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2007-12-18 01:53:16 +0000
commitef7926ed6dedfd1726007f60d6a3ba999d74f2bf (patch)
tree291813c72a6a677a4ec4ad2d406b9e06258768c4 /net/netembryo
parent37b5b6985dbeea19c8f8c0aa90e2a37def5733f0 (diff)
Notes
Diffstat (limited to 'net/netembryo')
-rw-r--r--net/netembryo/Makefile31
-rw-r--r--net/netembryo/distinfo3
-rw-r--r--net/netembryo/pkg-descr4
-rw-r--r--net/netembryo/pkg-plist9
4 files changed, 47 insertions, 0 deletions
diff --git a/net/netembryo/Makefile b/net/netembryo/Makefile
new file mode 100644
index 000000000000..287e78078f9d
--- /dev/null
+++ b/net/netembryo/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: netembryo
+# Date created: 7 November 2007
+# Whom: Emmanuel Richiardone (err@tollari.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= netembryo
+PORTVERSION= 0.0.4
+CATEGORIES= net
+MASTER_SITES= http://live.polito.it/files/downloads/netembryo/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= err@tollari.org
+COMMENT= A network abstraction library used by for feng, libnemesi, felix
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+USE_GNOME= pkgconfig gnomehack
+
+OPTIONS= SCTP "Don't check if SCTP is present" off
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700028 && ! defined(WITH_SCTP)
+IGNORE= sorry, please use FreeBSD 7.x or patch your system for SCTP (http://www.sctp.org/download.html) and use WITH_SCTP=YES
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/netembryo/distinfo b/net/netembryo/distinfo
new file mode 100644
index 000000000000..17b0927fccf0
--- /dev/null
+++ b/net/netembryo/distinfo
@@ -0,0 +1,3 @@
+MD5 (netembryo-0.0.4.tar.bz2) = 1eea3fb7dbf3e945744384f216c845af
+SHA256 (netembryo-0.0.4.tar.bz2) = c623c19eb65583a293f2815a72259bcfb8411a5a98f07c77256b20bdf59ca0bb
+SIZE (netembryo-0.0.4.tar.bz2) = 452509
diff --git a/net/netembryo/pkg-descr b/net/netembryo/pkg-descr
new file mode 100644
index 000000000000..f3c624313029
--- /dev/null
+++ b/net/netembryo/pkg-descr
@@ -0,0 +1,4 @@
+Netembryo is a network abstraction library plus some misc
+utility functions used as foundation for feng, libnemesi, felix.
+
+WWW: http://live.polito.it/netembryo
diff --git a/net/netembryo/pkg-plist b/net/netembryo/pkg-plist
new file mode 100644
index 000000000000..c66c1b2d1755
--- /dev/null
+++ b/net/netembryo/pkg-plist
@@ -0,0 +1,9 @@
+include/netembryo/url.h
+include/netembryo/rtsp_errors.h
+include/netembryo/wsocket.h
+lib/libnetembryo.a
+lib/libnetembryo.la
+lib/libnetembryo.so
+lib/libnetembryo.so.4
+libdata/pkgconfig/libnetembryo.pc
+@dirrm include/netembryo