aboutsummaryrefslogtreecommitdiff
path: root/net/netmap/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-01-19 09:28:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-01-19 09:28:21 +0000
commit177df99bd7b7ba397069cafa7191a43c0df4c159 (patch)
treef7507675e918e36c1c75e3fa13c10efba1be88f3 /net/netmap/Makefile
parent15bafe26e93fe1cffbf3929209d8db99a4737deb (diff)
Notes
Diffstat (limited to 'net/netmap/Makefile')
-rw-r--r--net/netmap/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/net/netmap/Makefile b/net/netmap/Makefile
index 9cfaa44575a1..024aa6ce582e 100644
--- a/net/netmap/Makefile
+++ b/net/netmap/Makefile
@@ -10,15 +10,18 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/NetMap%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Make a graphical representation of the surrounding network
+LICENSE= GPLv2
+
RUN_DEPENDS= dotty:${PORTSDIR}/graphics/graphviz
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/makelist bin/netmap
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/makelist/makelist ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/netmap/netmap ${PREFIX}/bin
+.for i in makelist netmap
+ (cd ${WRKSRC}/${i} && ${INSTALL_PROGRAM} ${i} \
+ ${STAGEDIR}${PREFIX}/bin)
+.endfor
.include <bsd.port.mk>