aboutsummaryrefslogtreecommitdiff
path: root/net/netsed/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-10-31 10:10:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-10-31 10:10:59 +0000
commit30f73c2e506da93b9b52f1608bab09c2e620d9fc (patch)
treef2bf0f2d361db7b82aafe4dda8c6e57e9fda7b69 /net/netsed/Makefile
parent72003f355e41d683b93785382dda0b0e00aa2948 (diff)
downloadports-30f73c2e506da93b9b52f1608bab09c2e620d9fc.tar.gz
ports-30f73c2e506da93b9b52f1608bab09c2e620d9fc.zip
Notes
Diffstat (limited to 'net/netsed/Makefile')
-rw-r--r--net/netsed/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/net/netsed/Makefile b/net/netsed/Makefile
index 92b4bcd5b8b1..76fc3dcfda60 100644
--- a/net/netsed/Makefile
+++ b/net/netsed/Makefile
@@ -1,6 +1,6 @@
-# Ports collection makefile for: netsed
-# Date created: Jan 9 2000
-# Whom: Roman Shterenzon <roman@xpert.com>
+# Ports collection makefile for: NetSED
+# Date created: Jan 9 2000
+# Whom: Roman Shterenzon <roman@xpert.com>
#
# $FreeBSD$
#
@@ -9,21 +9,25 @@ PORTNAME= netsed
PORTVERSION= 0.01
PORTREVISION= 1
CATEGORIES= net security
-MASTER_SITES= http://dione.ids.pl/~lcamtuf/ \
- http://lcamtuf.na.export.pl/
+MASTER_SITES= http://dione.ids.pl/~lcamtuf/
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Alters the contents of packets in real-time
+MAKE_ARGS= CFLAGS="${CFLAGS}"
+
WRKSRC= ${WRKDIR}
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/netsed ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/netsed
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/netsed
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>