aboutsummaryrefslogtreecommitdiff
path: root/net/neubot
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2012-01-28 14:23:37 +0000
committerThierry Thomas <thierry@FreeBSD.org>2012-01-28 14:23:37 +0000
commite4ea5b3f706653340db67d238270f7fa990a9879 (patch)
treed448d34aeda6feed02c72641c6d54ed81d219991 /net/neubot
parentb2d45d2ecde6f0ecb8727dcc36bb718c874fcc39 (diff)
downloadports-e4ea5b3f706653340db67d238270f7fa990a9879.tar.gz
ports-e4ea5b3f706653340db67d238270f7fa990a9879.zip
Notes
Diffstat (limited to 'net/neubot')
-rw-r--r--net/neubot/Makefile2
-rw-r--r--net/neubot/distinfo4
-rw-r--r--net/neubot/files/neubotd.in2
-rw-r--r--net/neubot/files/patch-Makefile15
-rw-r--r--net/neubot/files/pkg_message.in3
-rw-r--r--net/neubot/pkg-plist14
6 files changed, 33 insertions, 7 deletions
diff --git a/net/neubot/Makefile b/net/neubot/Makefile
index f483afb5dd31..58bbadfe6688 100644
--- a/net/neubot/Makefile
+++ b/net/neubot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= neubot
-PORTVERSION= 0.4.5
+PORTVERSION= 0.4.6
CATEGORIES= net
MASTER_SITES= http://releases.neubot.org/_packages/
diff --git a/net/neubot/distinfo b/net/neubot/distinfo
index a83be5792225..3ae0cab1d786 100644
--- a/net/neubot/distinfo
+++ b/net/neubot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (neubot-0.4.5.tar.gz) = 23a3ba783a2926bcee10ec41632c5f76d2ef4eba36f812cbbe92084b85ca3078
-SIZE (neubot-0.4.5.tar.gz) = 574215
+SHA256 (neubot-0.4.6.tar.gz) = a609aa9cd8a8946aa185de9c6247c919d60e9470c4babda9c53f70530c2a9cb9
+SIZE (neubot-0.4.6.tar.gz) = 597769
diff --git a/net/neubot/files/neubotd.in b/net/neubot/files/neubotd.in
index a4614d54bc30..65da8360b6ee 100644
--- a/net/neubot/files/neubotd.in
+++ b/net/neubot/files/neubotd.in
@@ -9,7 +9,7 @@
# Add the following line to /etc/rc.conf to enable `neubotd':
#
-#neubotd_enable="YES"
+# neubotd_enable="YES"
#
. /etc/rc.subr
diff --git a/net/neubot/files/patch-Makefile b/net/neubot/files/patch-Makefile
index b61e5fe23d5a..c897c3e7cb5c 100644
--- a/net/neubot/files/patch-Makefile
+++ b/net/neubot/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2011-10-25 20:20:56.000000000 +0200
-+++ Makefile 2011-11-01 21:08:46.000000000 +0100
-@@ -124,7 +124,7 @@
+--- Makefile.orig 2012-01-23 15:46:31.000000000 +0100
++++ Makefile 2012-01-28 14:53:37.000000000 +0100
+@@ -125,7 +125,7 @@
# [2] http://bit.ly/ayYyAR (debian.org)
#
DESTDIR =
@@ -9,3 +9,12 @@
LOCALSTATEDIR = /var/neubot
PREFIX = /usr/local
BINDIR = $(PREFIX)/bin
+@@ -150,7 +150,7 @@
+ $(INSTALL) -d $(DESTDIR)$(MANDIR)/$$DIR; \
+ test $$? || exit 1; \
+ done
+- for FILE in `cd UNIX/man && find . -type f`; do \
++ for FILE in `cd UNIX/man && find . -type f -a ! -name "*.gz"`; do \
+ gzip -9c UNIX/man/$$FILE > UNIX/man/$$FILE.gz; \
+ test $$? || exit 1; \
+ $(INSTALL) -m644 UNIX/man/$$FILE.gz $(DESTDIR)$(MANDIR)/$$FILE.gz; \
diff --git a/net/neubot/files/pkg_message.in b/net/neubot/files/pkg_message.in
index aebecc071eec..9377e24b1b2e 100644
--- a/net/neubot/files/pkg_message.in
+++ b/net/neubot/files/pkg_message.in
@@ -5,5 +5,8 @@ program.
To start the daemon, add the following line to /etc/rc.conf:
neubotd_enable="YES"
+
+When upgrading, don't forget to restart the daemon, in order to migrate its
+database if needed.
==============================================================================
diff --git a/net/neubot/pkg-plist b/net/neubot/pkg-plist
index 4e6d8309a095..bf370d9a43bc 100644
--- a/net/neubot/pkg-plist
+++ b/net/neubot/pkg-plist
@@ -70,6 +70,8 @@ share/icons/hicolor/scalable/apps/neubot.svg
%%DATADIR%%/http/stream.pyc
%%DATADIR%%/log.py
%%DATADIR%%/log.pyc
+%%DATADIR%%/log_api.py
+%%DATADIR%%/log_api.pyc
%%DATADIR%%/main/__init__.py
%%DATADIR%%/main/__init__.pyc
%%DATADIR%%/main/browser.py
@@ -100,6 +102,8 @@ share/icons/hicolor/scalable/apps/neubot.svg
%%DATADIR%%/net/stream.pyc
%%DATADIR%%/notifier/__init__.py
%%DATADIR%%/notifier/__init__.pyc
+%%DATADIR%%/notifier/macos.py
+%%DATADIR%%/notifier/macos.pyc
%%DATADIR%%/notifier/unix.py
%%DATADIR%%/notifier/unix.pyc
%%DATADIR%%/notify.py
@@ -118,6 +122,16 @@ share/icons/hicolor/scalable/apps/neubot.svg
%%DATADIR%%/rendezvous/server.pyc
%%DATADIR%%/rootdir.py
%%DATADIR%%/rootdir.pyc
+%%DATADIR%%/runner_api.py
+%%DATADIR%%/runner_api.pyc
+%%DATADIR%%/runner_clnt.py
+%%DATADIR%%/runner_clnt.pyc
+%%DATADIR%%/runner_core.py
+%%DATADIR%%/runner_core.pyc
+%%DATADIR%%/runner_lst.py
+%%DATADIR%%/runner_lst.pyc
+%%DATADIR%%/runner_rendezvous.py
+%%DATADIR%%/runner_rendezvous.pyc
%%DATADIR%%/server.py
%%DATADIR%%/server.pyc
%%DATADIR%%/simplejson/__init__.py