aboutsummaryrefslogtreecommitdiff
path: root/net/ngrep
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 06:34:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 06:34:05 +0000
commitac818fc7df67839053a8b7e6c0139da668b9c2d2 (patch)
tree99001edb2fb6eba2392e4ff305e6b1a997e7561c /net/ngrep
parentfd0bfa7a6d9bcd5e08d8238c45af05264a52330a (diff)
downloadports-ac818fc7df67839053a8b7e6c0139da668b9c2d2.tar.gz
ports-ac818fc7df67839053a8b7e6c0139da668b9c2d2.zip
Notes
Diffstat (limited to 'net/ngrep')
-rw-r--r--net/ngrep/Makefile32
1 files changed, 14 insertions, 18 deletions
diff --git a/net/ngrep/Makefile b/net/ngrep/Makefile
index 6c89b541f89d..0acada1305ac 100644
--- a/net/ngrep/Makefile
+++ b/net/ngrep/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: ngrep
-# Date created: Sat Jan 01, 2000
-# Whom: David O'Brien (obrien@NUXI.com)
-#
+# Created by: David O'Brien (obrien@NUXI.com)
# $FreeBSD$
-#
PORTNAME= ngrep
PORTVERSION= 1.45
@@ -22,9 +17,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-pcap-restart
MAKE_JOBS_UNSAFE= yes
-OPTIONS= PCRE "Use PCRE instead of GNU regex" on \
- PORTS_PCAP "Use ports PCAP instead of system PCAP" off \
- IPV6 "Enable IPv6 support" on
+OPTIONS_DEFINE= PCRE PORTS_PCAP IPV6 DOCS
+OPTIONS_DEFAULT= PCRE
+PCRE_DESC= Use PCRE instead of GNU regex
+PORTS_PCAP_DESC= Use ports PCAP instead of system PCAP
MAN8= ngrep.8
PLIST_FILES= bin/ngrep
@@ -32,31 +28,31 @@ PLIST_FILES= bin/ngrep
PORTDOCS= CHANGES.txt CREDITS.txt INSTALL.txt LICENSE.txt \
README.txt REGEX.txt
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PCRE)
+.if ${PORT_OPTIONS:MPCRE}
CONFIGURE_ARGS+= --enable-pcre
.endif
-.if !defined(WITH_PORTS_PCAP)
-CONFIGURE_ARGS+= --with-pcap-includes=/usr/include
-.else
+.if ${PORT_OPTIONS:MPORTS_PCAP}
CONFIGURE_ARGS+= --with-pcap-includes=${LOCALBASE}/include
BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
+.else
+CONFIGURE_ARGS+= --with-pcap-includes=/usr/include
.endif
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
.endif
post-patch:
-.if defined(WITH_PORTS_PCAP)
+.if ${PORT_OPTIONS:MPORTS_PCAP}
@${REINPLACE_CMD} -e "s|-lpcap|${LOCALBASE}/lib/libpcap.a|g" \
${WRKSRC}/Makefile.in ${WRKSRC}/configure
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
@if [ -f ${WRKSRC}/${file} ]; then \
@@ -67,4 +63,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>