aboutsummaryrefslogtreecommitdiff
path: root/net/ngrep
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2013-10-08 06:20:34 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2013-10-08 06:20:34 +0000
commit1f92d2bde8cd07d3751e9a6112230944439e293e (patch)
tree06269b16bb9158f52981c0d23c7f888931e1b87e /net/ngrep
parent66ee3f05dc1b4b7bafb94cde68b062a515e250e6 (diff)
downloadports-1f92d2bde8cd07d3751e9a6112230944439e293e.tar.gz
ports-1f92d2bde8cd07d3751e9a6112230944439e293e.zip
Notes
Diffstat (limited to 'net/ngrep')
-rw-r--r--net/ngrep/Makefile6
-rw-r--r--net/ngrep/files/patch-Makefile.in13
2 files changed, 14 insertions, 5 deletions
diff --git a/net/ngrep/Makefile b/net/ngrep/Makefile
index 42edcb555867..74e543e335b6 100644
--- a/net/ngrep/Makefile
+++ b/net/ngrep/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ngrep
PORTVERSION= 1.45
+PORTREVISION= 1
CATEGORIES= net security
MASTER_SITES= SF
@@ -11,14 +12,13 @@ COMMENT= Network grep
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_BZIP2= yes
-USE_GMAKE= yes
-ALL_TARGET= ngrep
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-pcap-restart
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= PCRE PORTS_PCAP IPV6 DOCS
-OPTIONS_DEFAULT= PCRE
+OPTIONS_DEFAULT= PCRE IPV6
PCRE_DESC= Use PCRE instead of GNU regex
PORTS_PCAP_DESC= Use ports PCAP instead of system PCAP
diff --git a/net/ngrep/files/patch-Makefile.in b/net/ngrep/files/patch-Makefile.in
index 61eb3d072ceb..9347ae0254a6 100644
--- a/net/ngrep/files/patch-Makefile.in
+++ b/net/ngrep/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Thu Feb 24 17:24:22 2005
-+++ Makefile.in Thu Feb 24 17:24:27 2005
+--- Makefile.in.orig 2006-11-29 00:35:37.000000000 +1100
++++ Makefile.in 2013-10-09 02:17:53.000000000 +1100
@@ -25,7 +25,7 @@
bindir = $(prefix)/bin
@@ -9,3 +9,12 @@
BINDIR_INSTALL = $(prefix)/bin
MANDIR_INSTALL = $(mandir)/man8
+@@ -63,7 +63,7 @@
+ rm -f config.status config.cache config.log config.h Makefile
+
+ $(REGEX_OBJS): $(REGEX_OBJS:.o=.c) $(REGEX_DIR)/*.h
+- $(MAKE) $(MAKEFLAGS) -C $(REGEX_DIR) $(notdir $(REGEX_OBJS))
++ $(MAKE) -C $(REGEX_DIR) $(notdir $(REGEX_OBJS))
+
+ $(OBJS): Makefile ngrep.c ngrep.h
+