aboutsummaryrefslogtreecommitdiff
path: root/net/nic
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-30 16:45:40 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-30 16:45:40 +0000
commit1b16e1817e9a6fa85495abec983517611257914d (patch)
tree951e639ef116b861345c66ba6fb6fc05c255610d /net/nic
parent66f32fc34e517b754ceb0d87943a663e55a2ad44 (diff)
downloadports-1b16e1817e9a6fa85495abec983517611257914d.tar.gz
ports-1b16e1817e9a6fa85495abec983517611257914d.zip
Notes
Diffstat (limited to 'net/nic')
-rw-r--r--net/nic/Makefile10
-rw-r--r--net/nic/pkg-message4
-rw-r--r--net/nic/pkg-plist1
3 files changed, 13 insertions, 2 deletions
diff --git a/net/nic/Makefile b/net/nic/Makefile
index a5ae92240210..4cd91cf9c2f0 100644
--- a/net/nic/Makefile
+++ b/net/nic/Makefile
@@ -18,8 +18,10 @@ NO_BUILD= yes
USE_REINPLACE= yes
+REINPLACE_ARGS= -i.beforeNic
DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL
CONFFILE= conf.php html.php menu.php
+SUB_DIRS= config graphics lib templates
LHORDEDIR?= www/horde
LNICDIR?= ${LHORDEDIR}/nic
@@ -34,8 +36,9 @@ HORDE_INC= ${LOCALBASE}/etc/horde
do-install:
@${MKDIR} ${NICDIR}
- @${CP} -Rp ${WRKSRC}/config ${WRKSRC}/graphics ${WRKSRC}/lib ${NICDIR}
- @${CP} -Rp ${WRKSRC}/templates ${NICDIR}
+.for REP in ${SUB_DIRS}
+ @${CP} -Rp ${WRKSRC}/${REP} ${NICDIR}
+.endfor
@${CP} -p ${WRKSRC}/*.php ${NICDIR}
.for FILE in ${CONFFILE}
@if [ ! -f ${CONFDIR}/${FILE} ]; then \
@@ -47,8 +50,11 @@ do-install:
@${CP} -p ${FILESDIR}/httpd.conf.nic ${HORDE_INC}
@${REINPLACE_CMD} -e "s:/home/httpd/html/horde/nic:${NICDIR}:g" \
${HORDE_INC}/httpd.conf.nic
+ @${RM} ${HORDE_INC}/httpd.conf.nic.beforeNic
@${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTNIC::" \
${HORDEDIR}/config/registry.php
+ @${CP} -p ${HORDEDIR}/config/registry.php \
+ ${HORDEDIR}/config/registry.php.afterNic
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
diff --git a/net/nic/pkg-message b/net/nic/pkg-message
index dc3b141f3692..623119cd97df 100644
--- a/net/nic/pkg-message
+++ b/net/nic/pkg-message
@@ -7,4 +7,8 @@ You may tune the configuration files located in
%%CONFDIR%%/, specially the files conf.php.
To protect your configuration files, you have to restart Apache.
+
+N.B.: if you don't have a file /usr/local/lib/php/Net/Socket.php, you
+===== have to install it from
+ <URL:http://pear.php.net/get/Net_Socket-1.0.1.tgz>.
************************************************************************
diff --git a/net/nic/pkg-plist b/net/nic/pkg-plist
index 2bdf1fef5509..af531924a342 100644
--- a/net/nic/pkg-plist
+++ b/net/nic/pkg-plist
@@ -71,3 +71,4 @@ etc/horde/httpd.conf.nic
@dirrm %%NICDIR%%/templates
@dirrm %%NICDIR%%
%%PORTDOCS%%@dirrm share/doc/nic
+@unexec if cmp -s %D/www/horde/config/registry.php %D/www/horde/config/registry.php.afterNic; then rm -f %D/www/horde/config/registry.php.afterNic; mv %D/www/horde/config/registry.php.beforeNic %D/www/horde/config/registry.php; fi