aboutsummaryrefslogtreecommitdiff
path: root/net/nocatauth-server/Makefile
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2004-01-03 06:26:58 +0000
committerBruce M Simpson <bms@FreeBSD.org>2004-01-03 06:26:58 +0000
commitde7dcb54873ee7da6ab453a4d533966f5f93dc8f (patch)
tree755c1efa037f66333cb72a3cc19b7f50141d9554 /net/nocatauth-server/Makefile
parent13dedb464a924cdb6b94ff4d675798a784c9fa40 (diff)
downloadports-de7dcb54873ee7da6ab453a4d533966f5f93dc8f.tar.gz
ports-de7dcb54873ee7da6ab453a4d533966f5f93dc8f.zip
Notes
Diffstat (limited to 'net/nocatauth-server/Makefile')
-rw-r--r--net/nocatauth-server/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/net/nocatauth-server/Makefile b/net/nocatauth-server/Makefile
new file mode 100644
index 000000000000..65c3a01c0ddf
--- /dev/null
+++ b/net/nocatauth-server/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: nocatauth-server
+# Date created: 19 November 2003
+# Whom: Bruce M Simpson <bms@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nocatauth-server
+PORTVERSION= 0.82
+CATEGORIES= net
+MASTER_SITES= http://nocat.net/download/NoCatAuth/
+DISTNAME= NoCatAuth-${PORTVERSION}
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Open 802.11 Authentication Server
+
+RUN_DEPENDS= \
+ ${LOCALBASE}/bin/gpg:${PORTSDIR}/security/gnupg
+
+CONFLICTS= nocatauth-gateway-*
+
+NO_BUILD= yes
+INSTALL_TARGET= authserv
+
+USE_PERL5_RUN= yes
+USE_GMAKE= yes
+USE_SUBMAKE= yes
+
+WRAP_USER?= nocat
+NOCATDIR?= nocat
+
+MAKE_ARGS+= DESTDIR=${PREFIX}/ PREFIX=${NOCATDIR}
+MAKE_ARGS+= WRAP_USER=${WRAP_USER}
+MAKE_ARGS+= -w
+
+pre-install:
+ @( ${FIND} ${WRKDIR} -type f -name '*.orig' -exec ${RM} '{}' ';' )
+ @${SETENV} NOCAT_DIR="${PREFIX}/${NOCATDIR}" WRAP=${WRAP_USER} \
+ ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+.include <bsd.port.mk>