aboutsummaryrefslogtreecommitdiff
path: root/net/nqptp/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-11-08 17:51:31 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-11-08 17:51:31 +0000
commitdea8b5a8aaf0137b65441be83930e676ce102770 (patch)
tree3667b7e7855a9e98c80ece97e3d997ccd461aa50 /net/nqptp/Makefile
parent07b08f309322728db448e787787e69e11bf0dcf9 (diff)
downloadports-dea8b5a8aaf0137b65441be83930e676ce102770.tar.gz
ports-dea8b5a8aaf0137b65441be83930e676ce102770.zip
Diffstat (limited to 'net/nqptp/Makefile')
-rw-r--r--net/nqptp/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net/nqptp/Makefile b/net/nqptp/Makefile
new file mode 100644
index 000000000000..654875b273ef
--- /dev/null
+++ b/net/nqptp/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= nqptp
+DISTVERSION= 1.1-dev-170
+DISTVERSIONSUFFIX= -gc71b49a
+CATEGORIES= net
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Not Quite PTP
+WWW= https://github.com/mikebrady/nqptp
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= autoreconf
+USE_GITHUB= yes
+GH_ACCOUNT= mikebrady
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/nqptp \
+ etc/rc.d/nqptp
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/nqptp.freebsd \
+ ${STAGEDIR}$/${PREFIX}/etc/rc.d/${PORTNAME}
+
+.include <bsd.port.mk>