aboutsummaryrefslogtreecommitdiff
path: root/net/ns
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-29 09:33:40 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-29 09:33:40 +0000
commit302886747cdcb48e55ea1ea653584e8029ab6eda (patch)
tree743c6308f5a4b698e3725cf08623c3834b8a4bdd /net/ns
parent81f872958299f92774429dcc83f5c83145a2e9f9 (diff)
downloadports-302886747cdcb48e55ea1ea653584e8029ab6eda.tar.gz
ports-302886747cdcb48e55ea1ea653584e8029ab6eda.zip
Notes
Diffstat (limited to 'net/ns')
-rw-r--r--net/ns/Makefile38
1 files changed, 25 insertions, 13 deletions
diff --git a/net/ns/Makefile b/net/ns/Makefile
index 7b24e817867a..9c59f26ece9e 100644
--- a/net/ns/Makefile
+++ b/net/ns/Makefile
@@ -1,38 +1,50 @@
-# New ports collection makefile for: ns-2
-# Date created: 26 April 1999
-# Whom: obonilla
-#
+# Created by: Oscar Bonilla <obonilla@fisicc-ufm.edu>
# $FreeBSD$
-#
PORTNAME= ns
PORTVERSION= 2.35
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}nam/${PORTNAME}-2/${PORTVERSION}
-DISTFILES= ${PORTNAME}-src-${PORTVERSION}.tar.gz
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= masaki@club.kyutech.ac.jp
COMMENT= Discrete event simulator for networking research
BUILD_DEPENDS= ${LOCALBASE}/lib/libtclcl.a:${PORTSDIR}/devel/tclcl
+USES= gmake
+USE_TK= 85+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tcl-ver=${TCL_VER} \
+ --with-tk-ver=${TK_VER} \
+ --x-libraries=${LOCALBASE}/lib \
+ --x-includes=${LOCALBASE}/include
+
+WRKSRC= ${WRKDIR}/ns-${PORTVERSION}
+
MAN1= ns.1
-MANCOMPRESSED= no
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl-ver=${TCL_VER} --with-tk-ver=${TK_VER} --x-libraries=${LOCALBASE}/lib --x-includes=${LOCALBASE}/include
-USE_GMAKE= yes
-USE_TK= 85+
+OPTIONS_DEFINE= EXAMPLES
+
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s,Tcl_GetHashKey,static_cast<char*>&," \
+ ${WRKSRC}/pushback/ident-tree.h \
+ ${WRKSRC}/webcache/pagepool.cc
+ @${REINPLACE_CMD} -e "/^CFLAGS =/s,$$, -DUSE_INTERP_RESULT," \
+ ${WRKSRC}/indep-utils/webtrace-conv/dec/Makefile.in \
+ ${WRKSRC}/indep-utils/webtrace-conv/epa/Makefile.in \
+ ${WRKSRC}/indep-utils/webtrace-conv/nlanr/Makefile.in \
+ ${WRKSRC}/indep-utils/webtrace-conv/ucb/Makefile.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ns ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ns.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/tcl/ex/*.tcl ${EXAMPLESDIR}
.endif