aboutsummaryrefslogtreecommitdiff
path: root/net/nss-pam-ldapd
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-01-16 00:32:48 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-01-16 00:32:48 +0000
commite6389e2f430152e8e7051d7489c7ff70f1142c1a (patch)
tree16034f52dd612e4466a90f6d538bb9075fdf024d /net/nss-pam-ldapd
parent29ec9c184b2c39562458f6ef1130a293423bae8c (diff)
Notes
Diffstat (limited to 'net/nss-pam-ldapd')
-rw-r--r--net/nss-pam-ldapd/Makefile52
-rw-r--r--net/nss-pam-ldapd/distinfo4
2 files changed, 31 insertions, 25 deletions
diff --git a/net/nss-pam-ldapd/Makefile b/net/nss-pam-ldapd/Makefile
index aabaf3bc5c54..e7580d298bb9 100644
--- a/net/nss-pam-ldapd/Makefile
+++ b/net/nss-pam-ldapd/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= nss-pam-ldapd
-PORTVERSION= 0.8.10
+PORTVERSION= 0.8.12
CATEGORIES= net
MASTER_SITES= http://arthurdejong.org/nss-pam-ldapd/
@@ -33,13 +33,20 @@ NSLCD_PIDFILE?= /var/run/nslcd.pid
NSLCD_SOCKET?= /var/run/nslcd.ctl
.if defined(SLAVE_PORT)
-OPTIONS= PAM "Build pam_ldap" on \
- NSS "Build nss support" on
-WITH_SASL=yes
+OPTIONS_DEFINE= SASL
+OPTIONS_MULTI= MG1
+OPTIONS_MULTI_MG1= PAM NSS
+PAM_DESC= Build pam_ldap
+NSS_DESC= Build nss support
+SASL_DESC= Build sasl support
+OPTIONS_DEFAULT= PAM NSS
CONFLICTS+= nss-pam-ldapd-[0-9]*
.else
-OPTIONS= NSS "Build nss support" on \
- PAM "Build pam_ldap" on
+OPTIONS_MULTI= MG1
+OPTIONS_MULTI_MG1= PAM NSS
+PAM_DESC= Build pam_ldap
+NSS_DESC= Build nss support
+OPTIONS_DEFAULT= PAM NSS
CONFLICTS+= nss-pam-ldapd-sasl-[0-9]*
.endif
@@ -61,14 +68,14 @@ CONFIGURE_ARGS+= --with-ldap-conf-file=${PREFIX}/etc/${CONFIG_FILE}
PLIST_SUB+= CONFIG="${CONFIG_FILE}"
SUB_LIST+= CONFIG_FILE="${PREFIX}/etc/${CONFIG_FILE}"
-.if defined(WITH_SASL)
+.if ${PORT_OPTIONS:MSASL}
WANT_OPENLDAP_SASL= yes
CONFIGURE_ARGS+= --enable-sasl
.else
CONFIGURE_ARGS+= --disable-sasl
.endif
-.if defined(WITH_PAM)
+.if ${PORT_OPTIONS:MPAM}
CONFIGURE_ARGS+= --enable-pam \
--with-pam-seclib-dir=${PREFIX}/lib \
--with-pam-ldap-soname=pam_ldap.so.${PAM_LDAP_SHMAJOR}
@@ -80,34 +87,33 @@ CONFIGURE_ARGS+= --disable-pam
PLIST_SUB+= PAM="@comment "
.endif
-.if defined(WITHOUT_NSS)
-CONFIGURE_ARGS+= --disable-nss
-PLIST_SUB+= NSS="@comment "
-SUB_LIST+= NSS_MESSAGE=""
-.else
+.if ${PORT_OPTIONS:MNSS}
CONFIGURE_ARGS+= --enable-nss
CONFLICTS+= nss_ldap-1.*
PLIST_SUB+= NSS=""
SUB_LIST+= NSS_MESSAGE="WARNING: Be sure to set uid and gid configuration parameters to make nslcd run under unprivileged user."
+.else
+CONFIGURE_ARGS+= --disable-nss
+PLIST_SUB+= NSS="@comment "
+SUB_LIST+= NSS_MESSAGE=""
.endif
# Won't hook this in to OPTIONS until PADL ports are at least DEPRECATED.
# It doesn't do the software any good to run as replacement for the PADL ports
# without running the daemon.
-.if defined(WITHOUT_NSLCD)
-CONFIGURE_ARGS+= --disable-nslcd
-PLIST_SUB+= NSLCD="@comment "
-.else
+.if ${PORT_OPTIONS:MNSLCD)
CONFIGURE_ARGS+= --enable-nslcd
PLIST_SUB+= NSLCD=""
MAN5+= nslcd.conf.5
MAN8+= nslcd.8
+.else
+CONFIGURE_ARGS+= --disable-nslcd --disable-pynslcd
+PLIST_SUB+= NSLCD="@comment "
.endif
-.if defined(WITHOUT_NSS) && defined(WITHOUT_PAM)
-BROKEN= Software is useless if both NSS and PAM are disabled.\
- Rerun 'make config' or 'portmaster --force-config'.
-.endif
+# these are unconditionally installed (bug filed upstream)
+MAN5+= nslcd.conf.5
+MAN8+= nslcd.8
post-extract:
@${REINPLACE_CMD} -e 's/\(INSTALL_\)\(.*\)) -D /\1\2) /' ${WRKSRC}/Makefile.in ${WRKSRC}/nss/Makefile.in
@@ -122,10 +128,10 @@ show-pkgmessage::
# file if it does not exist yet.
post-install: show-pkgmessage
@${INSTALL_DATA} ${WRKSRC}/nslcd.conf ${PREFIX}/etc/nslcd.conf.sample
-.if !defined(WITHOUT_NSS)
+.if ${PORT_OPTIONS:MNSS}
@${LN} -fs nss_ldap.so.${NSS_LDAP_SHMAJOR} ${PREFIX}/lib/nss_ldap.so
.endif
-.if !defined(WITHOUT_PAM)
+.if ${PORT_OPTIONS:MPAM}
@${LN} -fs pam_ldap.so.${PAM_LDAP_SHMAJOR} ${PREFIX}/lib/pam_ldap.so
.endif
diff --git a/net/nss-pam-ldapd/distinfo b/net/nss-pam-ldapd/distinfo
index 7e873881e7e2..e3697785e648 100644
--- a/net/nss-pam-ldapd/distinfo
+++ b/net/nss-pam-ldapd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nss-pam-ldapd-0.8.10.tar.gz) = 673a5e235a40fd9aac74082bc64d2ac2280fc155fb00b21092650d2c963e79cc
-SIZE (nss-pam-ldapd-0.8.10.tar.gz) = 475884
+SHA256 (nss-pam-ldapd-0.8.12.tar.gz) = d4bb255a796d59daa69e8c0aa790d15fb2a22e9706005d26e93ca52cf502ac10
+SIZE (nss-pam-ldapd-0.8.12.tar.gz) = 484453