aboutsummaryrefslogtreecommitdiff
path: root/net/nss-pam-ldapd
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2014-03-17 15:20:03 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2014-03-17 15:20:03 +0000
commit24cf422ffce49cbce1bc2c5bdbd7700aa5b70d44 (patch)
tree3a7ef08e955f4d07c33d9bd9c297d54332a8f9a5 /net/nss-pam-ldapd
parentf3c91320712a759c93503ce3149716ade2d41991 (diff)
Notes
Diffstat (limited to 'net/nss-pam-ldapd')
-rw-r--r--net/nss-pam-ldapd/Makefile24
-rw-r--r--net/nss-pam-ldapd/distinfo4
-rw-r--r--net/nss-pam-ldapd/files/nslcd.in4
3 files changed, 14 insertions, 18 deletions
diff --git a/net/nss-pam-ldapd/Makefile b/net/nss-pam-ldapd/Makefile
index da8faf4ab90d..883f1d1e1360 100644
--- a/net/nss-pam-ldapd/Makefile
+++ b/net/nss-pam-ldapd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nss-pam-ldapd
-PORTVERSION= 0.8.13
-PORTREVISION= 2
+PORTVERSION= 0.8.14
CATEGORIES= net
MASTER_SITES= http://arthurdejong.org/nss-pam-ldapd/ \
http://mirrors.rit.edu/zi/
@@ -15,9 +14,6 @@ LICENSE= LGPL21 LGPL3
LICENSE_COMB= dual
GNU_CONFIGURE= yes
-# Gmake seems to be not really needed anymore.
-# Gmake specific constructs are limited to maintainer targets
-# USE_GMAKE= yes
USE_OPENLDAP= yes
USE_RC_SUBR= nslcd
PAM_LDAP_SHMAJOR= 1
@@ -29,19 +25,19 @@ NSLCD_PIDFILE?= /var/run/nslcd.pid
NSLCD_SOCKET?= /var/run/nslcd.ctl
.if defined(SLAVE_PORT)
-OPTIONS_DEFINE= SASL
-OPTIONS_MULTI= MG1
+OPTIONS_DEFINE= SASL
+OPTIONS_MULTI= MG1
OPTIONS_MULTI_MG1= PAM NSS
-PAM_DESC= Build pam_ldap
-NSS_DESC= Build nss support
-SASL_DESC= Build sasl support
+PAM_DESC= Build pam_ldap
+NSS_DESC= Build nss support
+SASL_DESC= Build sasl support
OPTIONS_DEFAULT= PAM NSS
CONFLICTS+= nss-pam-ldapd-[0-9]*
.else
-OPTIONS_MULTI= MG1
+OPTIONS_MULTI= MG1
OPTIONS_MULTI_MG1= PAM NSS
-PAM_DESC= Build pam_ldap
-NSS_DESC= Build nss support
+PAM_DESC= Build pam_ldap
+NSS_DESC= Build nss support
OPTIONS_DEFAULT= PAM NSS
CONFLICTS+= nss-pam-ldapd-sasl-[0-9]*
.endif
@@ -56,7 +52,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-nslcd-pidfile=${NSLCD_PIDFILE} \
--with-nslcd-socket=${NSLCD_SOCKET} \
- --with-ldap-lib=openldap --disable-kerberos \
+ --with-ldap-lib=openldap \
--with-nss-ldap-soname=nss_ldap.so.${NSS_LDAP_SHMAJOR}
CONFIG_FILE= "nslcd.conf"
diff --git a/net/nss-pam-ldapd/distinfo b/net/nss-pam-ldapd/distinfo
index f824cd2ed536..e3f36446b006 100644
--- a/net/nss-pam-ldapd/distinfo
+++ b/net/nss-pam-ldapd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nss-pam-ldapd-0.8.13.tar.gz) = b792ae98c98402ac25db49d54c4c53b860d45c9a7a7e24587e03a5fda7ee5d22
-SIZE (nss-pam-ldapd-0.8.13.tar.gz) = 487295
+SHA256 (nss-pam-ldapd-0.8.14.tar.gz) = a29ceb9b7eda386ca38f16115ffec61425462cca6b5e560c44c3d51edc03a63f
+SIZE (nss-pam-ldapd-0.8.14.tar.gz) = 508949
diff --git a/net/nss-pam-ldapd/files/nslcd.in b/net/nss-pam-ldapd/files/nslcd.in
index 7ffdf2eb924c..ad9e1cb9989e 100644
--- a/net/nss-pam-ldapd/files/nslcd.in
+++ b/net/nss-pam-ldapd/files/nslcd.in
@@ -33,14 +33,14 @@ nslcd_prestart()
if checkyesno nslcd_supervisor ; then
notsupported=$(${command} -r 3>&1 1>&2 2>&3 | grep -c illegal)
if [ ${notsupported} -eq 0 ]; then
- command_args="-f -r %%PREFIX%%/sbin/nslcd -d"
+ command_args="-f -r %%PREFIX%%/sbin/nslcd -n"
else
echo "Your FreeBSD version's daemon(8) does not support supervision.";
echo "${name} was not started.";
exit 1
fi
else
- command_args="-f %%PREFIX%%/sbin/nslcd -d"
+ command_args="-f %%PREFIX%%/sbin/nslcd"
fi
}