aboutsummaryrefslogtreecommitdiff
path: root/net/nss_ldap
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-08-18 14:33:37 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-08-18 14:33:37 +0000
commitbe307a858cd71b8e1b1fc24fee6147490835b55b (patch)
treed1b2cd1618619b12b1592a236106584231e5523c /net/nss_ldap
parent7fd67a105f75bfe20c82438ad88d2c5f6ec644f4 (diff)
downloadports-be307a858cd71b8e1b1fc24fee6147490835b55b.tar.gz
ports-be307a858cd71b8e1b1fc24fee6147490835b55b.zip
Notes
Diffstat (limited to 'net/nss_ldap')
-rw-r--r--net/nss_ldap/Makefile4
-rw-r--r--net/nss_ldap/files/patch-ldap-nss.c8
2 files changed, 9 insertions, 3 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 21282770f878..17abf6310d29 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -23,7 +23,6 @@ USE_AUTOTOOLS= automake:19 aclocal:19 autoconf:262 autoheader:262
USE_LDCONFIG= yes
USE_OPENLDAP= yes
-
PLIST_FILES= etc/nss_ldap.conf.sample \
lib/nss_ldap.so.1
@@ -33,8 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --with-ldap-conf-file=${PREFIX}/etc/nss_ldap.conf \
--with-ldap-secret-file=${PREFIX}/etc/nss_ldap.secret \
--enable-rfc2307bis \
- --enable-paged-results \
- --enable-configurable-krb5-ccname-env
+ --enable-paged-results
MAN5= nss_ldap.5
diff --git a/net/nss_ldap/files/patch-ldap-nss.c b/net/nss_ldap/files/patch-ldap-nss.c
index 2622dc3b1726..297cc4d403f9 100644
--- a/net/nss_ldap/files/patch-ldap-nss.c
+++ b/net/nss_ldap/files/patch-ldap-nss.c
@@ -9,3 +9,11 @@
#include <sasl/sasl.h>
#elif defined(HAVE_SASL_H)
#include <sasl.h>
+@@ -84,7 +84,7 @@
+ #include <gssapi/gssapi.h>
+ #include <gssapi/gssapi_krb5.h>
+ #endif
+-#ifdef CONFIGURE_KRB5_CCNAME
++#if defined(CONFIGURE_KRB5_CCNAME) && defined(HAVE_KRB5_H)
+ #include <krb5.h>
+ #endif