aboutsummaryrefslogtreecommitdiff
path: root/net/nstxd/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-23 17:53:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-23 17:53:36 +0000
commiteaf6d87756fc794751c614f718fbaed4789a4b73 (patch)
tree26dd81a169ac5bcaabfb614d064b2940f94e7eca /net/nstxd/Makefile
parent003831588b731610eae0daf56c5395d4fc606a45 (diff)
downloadports-eaf6d87756fc794751c614f718fbaed4789a4b73.tar.gz
ports-eaf6d87756fc794751c614f718fbaed4789a4b73.zip
Notes
Diffstat (limited to 'net/nstxd/Makefile')
-rw-r--r--net/nstxd/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net/nstxd/Makefile b/net/nstxd/Makefile
new file mode 100644
index 000000000000..67d0962659f0
--- /dev/null
+++ b/net/nstxd/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: nstxd
+# Date created: 1 April 2007
+# Whom: nagilum
+#
+# $FreeBSD$
+#
+
+PORTNAME= nstxd
+PORTVERSION= 1.1b6
+CATEGORIES= net
+MASTER_SITES= http://www.nagilum.org/nstx/ \
+ http://ftp.debian.org/debian/pool/main/n/nstx/
+DISTNAME= nstx_1.1-beta6.orig
+
+PATCH_SITES= http://www.nagilum.org/nstx/ \
+ http://ftp.debian.org/debian/pool/main/n/nstx/
+PATCH_DIST_STRIP= -p1
+PATCHFILES= nstx_1.1-beta6-4.diff.gz
+
+MAINTAINER= freebsd@nagilum.org
+COMMENT= DNS tunnel server
+
+MAN8= nstxd.8
+USE_RC_SUBR+= nstxd
+
+WRKSRC= ${WRKDIR}/nstx-1.1-beta6
+
+ALL_TARGET= nstxd
+INSTALL_TARGET= nstxd
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nstxd ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/nstxd.8 ${PREFIX}/man/man8/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+ @${CAT} pkg-message
+.endif #NOPORTDOCS
+
+.include <bsd.port.mk>