aboutsummaryrefslogtreecommitdiff
path: root/net/ntalk/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-29 10:56:13 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-29 10:56:13 +0000
commitaa60fdf0b11fa57449bcd25e594402273da8c7a3 (patch)
treeb6531f179ec6c991a2a5d68e064d1cba957fb40b /net/ntalk/Makefile
parent67a948970aa0bf418f08194af7a6ff89378e8117 (diff)
downloadports-aa60fdf0b11fa57449bcd25e594402273da8c7a3.tar.gz
ports-aa60fdf0b11fa57449bcd25e594402273da8c7a3.zip
Notes
Diffstat (limited to 'net/ntalk/Makefile')
-rw-r--r--net/ntalk/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/ntalk/Makefile b/net/ntalk/Makefile
new file mode 100644
index 000000000000..80e63f6b8764
--- /dev/null
+++ b/net/ntalk/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: ntalk
+# Date created: 26 August 2001
+# Whom: Gea-Suan Lin (gslin@ccca.nctu.edu.tw)
+#
+# $FreeBSD$
+#
+
+PORTNAME= ntalk
+PORTVERSION= 0.3.1
+CATEGORIES= net
+MASTER_SITES= http://kab.w.interia.pl/
+
+MAINTAINER= gslin@ccca.nctu.edu.tw
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for FILE in COPYING ChangeLog INSTALL README
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>