aboutsummaryrefslogtreecommitdiff
path: root/net/ntop/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-02-07 16:40:37 +0000
committerClement Laforet <clement@FreeBSD.org>2004-02-07 16:40:37 +0000
commit9ad2b45ab89dd301c91a47ce2930ce33ac583d10 (patch)
treec24f0959e27fd9aa3460fb7772d784d7096c8400 /net/ntop/Makefile
parent29d345be06e1d8d713033e716107a15171e59f72 (diff)
downloadports-9ad2b45ab89dd301c91a47ce2930ce33ac583d10.tar.gz
ports-9ad2b45ab89dd301c91a47ce2930ce33ac583d10.zip
Notes
Diffstat (limited to 'net/ntop/Makefile')
-rw-r--r--net/ntop/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index b9f62808bfc7..741ca0ef57e7 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -48,14 +48,22 @@ MAN8= ntop.8
## WITH_LSOF: Add lsof as dependency.
## WITH_PCAP: Enable libpcap support.
## WITH_PCAP_PORT: Use libpcap from ports.
-## WITH_RRD: Enablerrdtool support.
+## WITH_RRD: Enable rrdtool support.
## WITH_XMLDUMP: Enable XML Dump support.
##
-## WITHOUT_GDBM: Disable gdbm support.
## WITHOUT_TCPWRAPPER: Disable TCP wrapper support.
##
+OPTIONS= LOCALE "Enable locale (i18n) support." Off \
+ LSOF "Add lsof as dependency." Off \
+ PCAP "Enable libpcap support." Off \
+ PCAP_PORT "Use libpcap from ports." Off \
+ RRD "Enablerrdtool support." Off \
+ XMLDUMP "Enable XML Dump support." Off \
+ TCPWRAPPER "Enable TCP wrapper support" On
-.if !defined(WITHOUT_TCPWRAPPER)
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_TCPWRAPPER)
CONFIGURE_ARGS+= --with-tcpwrap
.endif
@@ -124,4 +132,4 @@ post-install:
post-clean:
@${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>