aboutsummaryrefslogtreecommitdiff
path: root/net/ntop/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-03-22 19:25:52 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-03-22 19:25:52 +0000
commitfcd16abf2924b8f102de8673162827ed8868d5e8 (patch)
tree6c679c68102788e3153e80335223a2bbc4254914 /net/ntop/Makefile
parentf6cb1257bd3f9f0a4142c29e78409e471ce22fdd (diff)
downloadports-fcd16abf2924b8f102de8673162827ed8868d5e8.tar.gz
ports-fcd16abf2924b8f102de8673162827ed8868d5e8.zip
Notes
Diffstat (limited to 'net/ntop/Makefile')
-rw-r--r--net/ntop/Makefile36
1 files changed, 19 insertions, 17 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index cc36b4a5ccce..fbcc35708943 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ntop
PORTVERSION= 3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,18 +23,13 @@ LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
DBDIR?= /var/db
-# Only need to be interactive if it's the first install.
-.if !exists(${DBDIR}/ntop/ntop_pw.db)
-IS_INTERACTIVE= yes
-.endif
-
USE_GETOPT_LONG=yes
+USE_GNOME= libxml2
USE_GMAKE= yes
-USE_REINPLACE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-PLIST_SUB+= DBDIR=${DBDIR} \
+PLIST_SUB= DBDIR=${DBDIR} \
SHLIB=${PORTVERSION:S/.p/pre/}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=${DBDIR} \
@@ -48,6 +43,9 @@ CONFIGURE_ARGS+=--disable-ipv6
MAN8= ntop.8
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-deinstall
+SUB_LIST= DBDIR=${DBDIR}
USE_RC_SUBR= ntop.sh
##
@@ -55,12 +53,13 @@ USE_RC_SUBR= ntop.sh
## WITH_LOCALE: Enable locale (i18n) support.
## WITH_PCAP_PORT: Use libpcap from ports.
## WITH_XMLDUMP: Enable XML Dump support.
-##
+## WITH_ASDATA: Install AS data.
## WITHOUT_TCPWRAPPER: Disable TCP wrapper support.
##
OPTIONS= LOCALE "Enable locale (i18n) support." Off \
PCAP_PORT "Use libpcap from ports." Off \
XMLDUMP "Enable XML Dump support." Off \
+ ASDATA "Install AS data." Off \
TCPWRAPPER "Enable TCP wrapper support" On
.include <bsd.port.pre.mk>
@@ -71,20 +70,19 @@ CONFIGURE_ARGS+= --with-tcpwrap
.if defined(WITH_PCAP_PORT)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
-PCAP_ROOT= ${LOCALBASE}
+CONFIGURE_ARGS+= --with-pcap-root=${LOCALBASE}
.else
-PCAP_ROOT= /usr
+CONFIGURE_ARGS+= --with-pcap-root=/usr
.endif
-CONFIGURE_ARGS+= --with-pcap-root=${PCAP_ROOT}
-.if defined(WITH_LOCALE)
+.if defined(WITH_LOCALE) && !defined(WITHOUT_NLS)
USE_GETTEXT= yes
CONFIGURE_ARGS+= --enable-i18n \
--with-localedir=${LOCALBASE}/share/locale
.endif
.if defined(WITH_XMLDUMP)
-BROKEN= "Does not build with XML dump support"
+BROKEN= Does not build with XML dump support
LIB_DEPENDS+= gdome.8:${PORTSDIR}/textproc/gdome2
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include/libxml2 \
-I${LOCALBASE}/include/libxml2/libxml \
@@ -92,6 +90,13 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include/libxml2 \
-I${LOCALBASE}/include/glib-2.0"
.endif
+.if defined(WITH_ASDATA)
+INSTALL_TARGET+= install install-data-as
+PLIST_SUB+= ASDATA=""
+.else
+PLIST_SUB+= ASDATA="@comment "
+.endif
+
post-extract:
@${RM} ${WRKSRC}/configureextra/FREEBSD
@@ -99,8 +104,5 @@ post-install:
@${MKDIR} ${DBDIR}/ntop
@${CHOWN} -R nobody:nobody ${DBDIR}/ntop
@${RMDIR} ${PREFIX}/lib/plugins
- @if [ ! -f ${DBDIR}/ntop/ntop_pw.db ]; then \
- ${PREFIX}/bin/ntop -u nobody -A; \
- fi
.include <bsd.port.post.mk>