aboutsummaryrefslogtreecommitdiff
path: root/net/ntop
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-01-18 01:50:37 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-01-18 01:50:37 +0000
commit65672cdf8574ed33a8432b64451b07d1e43d6672 (patch)
tree25a584a1a99f02a72f65cf5cd6d069e7317d781e /net/ntop
parent70318e034d27139845dc9091a16f5f72d541200d (diff)
downloadports-65672cdf8574ed33a8432b64451b07d1e43d6672.tar.gz
ports-65672cdf8574ed33a8432b64451b07d1e43d6672.zip
Notes
Diffstat (limited to 'net/ntop')
-rw-r--r--net/ntop/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index 0fc2564c5b49..2043f09b71ee 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -53,10 +53,12 @@ USE_RC_SUBR= ntop.sh
## Available knobs:
## WITH_PCAP_PORT: Use libpcap from ports.
## WITH_XMLDUMP: Enable XML Dump support.
+## WITH_MAKO: Enable Host Map, Region View (installs py-mako)
##
OPTIONS= PCAP_PORT "Use libpcap from ports." Off \
XMLDUMP "Enable XML Dump support." Off \
- JUMBO_FRAMES "Jumbo Frames. Experimental." Off
+ JUMBO_FRAMES "Jumbo Frames. Experimental." Off \
+ MAKO "Install py-mako for Host Map, Region View " Off
.include <bsd.port.pre.mk>
@@ -81,6 +83,10 @@ CONFIGURE_ARGS+= --enable-jumbo-frames
# see http://www.cyberciti.biz/faq/freebsd-jumbo-frames-networking-configration/
.endif
+.if defined(WITH_MAKO)
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako
+.endif
+
.if ${OSVERSION} < 700000
BROKEN= does not configure on 6.X
.endif