aboutsummaryrefslogtreecommitdiff
path: root/net/ntp-devel/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2006-02-03 23:23:22 +0000
committerCy Schubert <cy@FreeBSD.org>2006-02-03 23:23:22 +0000
commit773cddcc2cb09f0cf8eceaaa4ae119e05a3c5a18 (patch)
tree769469e02a0c6b04d1356ca917aa3f6d00bf19f4 /net/ntp-devel/Makefile
parentadd7eaf094a9df9647db831aa8ce80ee9486a914 (diff)
Notes
Diffstat (limited to 'net/ntp-devel/Makefile')
-rw-r--r--net/ntp-devel/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/net/ntp-devel/Makefile b/net/ntp-devel/Makefile
new file mode 100644
index 000000000000..a06090a2e2f7
--- /dev/null
+++ b/net/ntp-devel/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: ntp
+# Date created: Di 5 Mai 1998 21:31:03 CEST
+# Whom: andreas
+#
+# $FreeBSD$
+#
+
+PORTNAME= ntp
+PORTVERSION= 4.2.0b
+CATEGORIES= net ipv6
+YEAR= 2006
+MONTH= 02
+DAY= 01
+SNAPSHOT_DIR= snapshots/ntp-dev/${YEAR}/${MONTH}
+MASTER_SITES= ftp://ftp.udel.edu/pub/ntp/ntp4/${SNAPSHOT_DIR}/ \
+ http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/${SNAPSHOT_DIR}/ \
+ ftp://ftp.archive.de.uu.net/pub/unix/ntp/ntp4/${SNAPSHOT_DIR} \
+ ftp://ftp.netlab.is.tsukuba.ac.jp/pub/network/ntp/ntp4/${SNAPSHOT_DIR}/
+DISTNAME= ${PORTNAME}-dev-${PORTVERSION:S/.r/-rc/}-${YEAR}${MONTH}${DAY}
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= The Network Time Protocol Distribution
+
+LATEST_LINK= ${PORTNAME}
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+MAN1= sntp.1
+
+.if defined(ENABLE_RAWDCF)
+CONFIGURE_ARGS+= --enable-RAWDCF
+.endif
+
+.if defined(WITHOUT_SSL)
+CONFIGURE_ARGS+= --without-crypto
+PLIST_SUB+= SSL="@comment "
+.else
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-openssl-incdir=${OPENSSLINC} \
+ --with-openssl-libdir=${OPENSSLLIB}
+PLIST_SUB+= SSL=""
+.endif
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${FIND} ${WRKSRC}/html -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+ @cd ${WRKSRC}/html && ${FIND} . -print | \
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} --quiet ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>