aboutsummaryrefslogtreecommitdiff
path: root/net/ntp-rc/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2015-04-03 10:39:41 +0000
committerCy Schubert <cy@FreeBSD.org>2015-04-03 10:39:41 +0000
commit6ab835ce7bef36f723b20b972f1c38fda2b44301 (patch)
tree35f196d8bc8ead8c8f662528e3d77837b74f7c63 /net/ntp-rc/Makefile
parentd539b1112933ef7334a47804b069177110159a70 (diff)
downloadports-6ab835ce7bef36f723b20b972f1c38fda2b44301.tar.gz
ports-6ab835ce7bef36f723b20b972f1c38fda2b44301.zip
Notes
Diffstat (limited to 'net/ntp-rc/Makefile')
-rw-r--r--net/ntp-rc/Makefile67
1 files changed, 67 insertions, 0 deletions
diff --git a/net/ntp-rc/Makefile b/net/ntp-rc/Makefile
new file mode 100644
index 000000000000..b3af593d89dd
--- /dev/null
+++ b/net/ntp-rc/Makefile
@@ -0,0 +1,67 @@
+# Created by: andreas
+# $FreeBSD$
+
+PORTNAME= ntp
+PORTVERSION= 4.2.8p2.r2
+CATEGORIES= net ipv6
+MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
+ http://archive.ntp.org/ntp4/ntp-4.2/ \
+ ftp://ftp.netlab.is.tsukuba.ac.jp/pub/network/ntp/ntp4/
+PKGNAMESUFFIX= -rc
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/P/p/:S/.r/-RC/}
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= The Network Time Protocol Distribution
+
+CONFLICTS ntp-[0-9].* ntp-devel-*
+
+GNU_CONFIGURE= yes
+OPTIONS_SUB= yes
+USES= pathfix shebangfix libtool
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
+
+NTP_SHEBANG_FILES= sbin/ntp-wait sbin/ntptrace
+
+.include "Makefile.inc"
+
+PERL_UTILS_USES= perl5
+
+SSL_USE= OPENSSL=yes
+SSL_CONFIGURE_OFF= --without-crypto
+
+IPV6_CONFIGURE_ENABLE= ipv6
+
+NTP_SIGND_CONFIGURE_ENABLE= ntp-signd
+
+NTPSNMPD_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
+NTPSNMPD_CONFIGURE_OFF= --without-ntpsnmpd
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MSSL}
+CONFIGURE_ARGS+= --with-openssl-incdir=${OPENSSLINC} \
+ --with-openssl-libdir=${OPENSSLLIB}
+.endif
+
+.for D in ${NTP_DRIVERS}
+.if ${PORT_OPTIONS:M${D}}
+CONFIGURE_ARGS+= --enable-${D}
+.endif
+.endfor
+
+# XXX Temporary hack. Remember to remove this next commit.
+post-extract:
+ @/usr/bin/touch ${WRKSRC}/scripts/build/checkHtmlFileDates
+ @${CHMOD} +x ${WRKSRC}/scripts/build/checkHtmlFileDates
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/* ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${FIND} ${WRKSRC}/html -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+ @cd ${WRKSRC}/html && ${FIND} . -print | \
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} --quiet ${STAGEDIR}${DOCSDIR}
+ @cd ${STAGEDIR}${PREFIX}; \
+ ${ECHO_CMD} ${NTP_SHEBANG_FILES} | ${XARGS} ${SED} -i '' ${_SHEBANG_REINPLACE_ARGS}
+
+.include <bsd.port.post.mk>