aboutsummaryrefslogtreecommitdiff
path: root/net/ntp-stable/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-08-30 14:00:15 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-08-30 14:00:15 +0000
commitcf53242161ec968c6fb57d8e09951f7d17c5287e (patch)
tree48d084cdeffd8b6232ae43015e751301406d87ed /net/ntp-stable/Makefile
parentf642e63f72689bb55ec93bb21aaae69a44dc4bd2 (diff)
downloadports-cf53242161ec968c6fb57d8e09951f7d17c5287e.tar.gz
ports-cf53242161ec968c6fb57d8e09951f7d17c5287e.zip
Notes
Diffstat (limited to 'net/ntp-stable/Makefile')
-rw-r--r--net/ntp-stable/Makefile31
1 files changed, 20 insertions, 11 deletions
diff --git a/net/ntp-stable/Makefile b/net/ntp-stable/Makefile
index 3d2dd950b38e..e4d55d4c36bc 100644
--- a/net/ntp-stable/Makefile
+++ b/net/ntp-stable/Makefile
@@ -8,7 +8,7 @@
PORTNAME= ntp
PORTVERSION= 4.2.0
PORTREVISION= 1
-CATEGORIES= net
+CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.udel.edu/pub/ntp/ntp4/ \
http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ \
ftp://ftp.archive.de.uu.net/pub/unix/ntp/ntp4/ \
@@ -19,23 +19,32 @@ MAINTAINER= cy@FreeBSD.org
COMMENT= The Network Time Protocol Distribution
LATEST_LINK= ${PORTNAME}
-# ntp's configure script created by autoconf 2.14.1 doesn't work
-# if GNU_CONFIGURE is defined
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX}
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.if defined(ENABLE_RAWDCF)
CONFIGURE_ARGS+= --enable-RAWDCF
.endif
+.if defined(WITHOUT_SSL)
+CONFIGURE_ARGS+= --without-crypto
+PLIST_SUB+= SSL="@comment "
+.else
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-openssl-incdir=${OPENSSLINC} \
+ --with-openssl-libdir=${OPENSSLLIB}
+PLIST_SUB+= SSL=""
+.endif
+
post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/conf/* ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/ntp
- ${TAR} -C ${WRKSRC}/html -cf - . | \
- ${TAR} -C ${PREFIX}/share/doc/ntp --unlink -xf -
- ${FIND} ${PREFIX}/share/doc/ntp | \
- ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- ${FIND} ${PREFIX}/share/doc/ntp -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+ @${MKDIR} ${DOCSDIR}
+ @${FIND} ${WRKSRC}/html -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+ @cd ${WRKSRC}/html && ${FIND} . -print | \
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} --quiet ${DOCSDIR}
.endif
.include <bsd.port.mk>