aboutsummaryrefslogtreecommitdiff
path: root/net/ntp/Makefile
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2000-04-01 04:28:04 +0000
committerMichael Haro <mharo@FreeBSD.org>2000-04-01 04:28:04 +0000
commitdd804234379b6caf53684caca788105ed6d8f6e8 (patch)
tree395631db25e79aaff261569d79f9bb57bb384b1a /net/ntp/Makefile
parentd6d51c267e4ad535232f52967c76f69f787f013b (diff)
downloadports-dd804234379b6caf53684caca788105ed6d8f6e8.tar.gz
ports-dd804234379b6caf53684caca788105ed6d8f6e8.zip
Notes
Diffstat (limited to 'net/ntp/Makefile')
-rw-r--r--net/ntp/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 0ea56a0e79f1..d900519bfbca 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -1,24 +1,29 @@
# New ports collection makefile for: ntp
-# Version required: 4.0.72
+# Version required: 4.0.99g
# Date created: Di 5 Mai 1998 21:31:03 CEST
# Whom: andreas
#
# $FreeBSD$
#
-DISTNAME= ntp-4.0.93a
+DISTNAME= ntp-4.0.99g
CATEGORIES= net
-MASTER_SITES= ftp://ftp.udel.edu/pub/ntp/testing/
+MASTER_SITES= ftp://ftp.udel.edu/pub/ntp/ntp4/
MAINTAINER= ports@FreeBSD.org
# ntp's configure script created by autoconf 2.14.1 doesn't work
-# our autoconf version 2.13 produces better results
-USE_AUTOCONF= yes
-GNU_CONFIGURE= yes
+# if GNU_CONFIGURE is defined
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
post-install:
- ${MKDIR} ${PREFIX}/share/doc/ntp
- ${CP} -r ${WRKSRC}/html/* ${PREFIX}/share/doc/ntp
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/ntp
+ ${TAR} -C ${WRKSRC}/html --exclude '.*' -cf - . | \
+ ${TAR} -C ${PREFIX}/share/doc/ntp --unlink -xf -
+ find ${PREFIX}/share/doc/ntp | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ find ${PREFIX}/share/doc/ntp -type f | xargs ${CHMOD} ${SHAREMODE}
+.endif
.include <bsd.port.mk>