aboutsummaryrefslogtreecommitdiff
path: root/net/ntraceroute
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-12-28 11:38:12 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-12-28 11:38:12 +0000
commitfedfe012271f62c0ac13bdab5703e9f923f693ca (patch)
tree45dc1249a1a7ee11ee3ca72dcf1be61044ea4b80 /net/ntraceroute
parent5bd996114188d28de0e4ceeddaee84f0b63ebb18 (diff)
downloadports-fedfe012271f62c0ac13bdab5703e9f923f693ca.tar.gz
ports-fedfe012271f62c0ac13bdab5703e9f923f693ca.zip
Notes
Diffstat (limited to 'net/ntraceroute')
-rw-r--r--net/ntraceroute/Makefile12
-rw-r--r--net/ntraceroute/files/patch-traceroute.c12
2 files changed, 9 insertions, 15 deletions
diff --git a/net/ntraceroute/Makefile b/net/ntraceroute/Makefile
index 965c7ac5015d..f54f8ccf4802 100644
--- a/net/ntraceroute/Makefile
+++ b/net/ntraceroute/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ntraceroute
PORTVERSION= 6.4.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= NETBSD/traceroute-nanog \
http://mirrors.rit.edu/zi/
@@ -22,11 +22,17 @@ EXTRACT_AFTER_ARGS= .
PLIST_FILES= sbin/${PORTNAME}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 1100030
+BUILD_FLAGS= -DBYTESWAP_IP_FLAGS -DBYTESWAP_IP_LEN
+.endif
+
do-build:
- ${CC} -o ${WRKSRC}/${PORTNAME} -lm \
+ ${CC} ${BUILD_FLAGS} -o ${WRKSRC}/${PORTNAME} -lm \
${WRKSRC}/${DISTFILES}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/ntraceroute/files/patch-traceroute.c b/net/ntraceroute/files/patch-traceroute.c
index 4c8d99e90854..e4e8c0dd459e 100644
--- a/net/ntraceroute/files/patch-traceroute.c
+++ b/net/ntraceroute/files/patch-traceroute.c
@@ -1,17 +1,5 @@
--- traceroute.c.orig 2016-09-02 21:07:07 UTC
+++ traceroute.c
-@@ -2,6 +2,11 @@
- /*
- * STILL BROKEN: traceroute -g on linux (LSRR)
- */
-+#include <string.h>
-+#if __FreeBSD_version >= 1100030
-+#define BYTESWAP_IP_FLAGS
-+#define BYTESWAP_IP_LEN
-+#endif
- #define TRACE_TOS 1
- #define SPRAY
- #define FIXT
@@ -798,7 +803,7 @@ struct opacket {
struct icmp icmp_probe;
} ip_payload;