aboutsummaryrefslogtreecommitdiff
path: root/net/nttcp/Makefile
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1998-12-08 04:18:08 +0000
committerBill Fumerola <billf@FreeBSD.org>1998-12-08 04:18:08 +0000
commite1487b22a82b87c7bb24d06c49a6053a07138642 (patch)
tree2484c11800a712d5d6bfd7daf9cad41a788a2526 /net/nttcp/Makefile
parent1c245ef25fc41354b5d6d14fed4a0a78cf0e149d (diff)
Notes
Diffstat (limited to 'net/nttcp/Makefile')
-rw-r--r--net/nttcp/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net/nttcp/Makefile b/net/nttcp/Makefile
new file mode 100644
index 000000000000..ddee0ec7fae5
--- /dev/null
+++ b/net/nttcp/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: nttcp
+# Version required: 1.3
+# Date created: 11 Nov 1998
+# Whom: Bill Fumerola <billf@chc-chimes.com>
+#
+# $Id: $
+#
+
+DISTNAME= nttcp-1.4
+CATEGORIES= net benchmarks
+MASTER_SITES= http://users.leo.org/~bartel/nttcp/ \
+ http://www.FreeBSD.org/~billf/
+
+MAINTAINER= billf@FreeBSD.org
+
+ALL_TARGET= nttcp
+MAN1= nttcp.1
+USE_GMAKE= yes
+MAKE_ENV+= CFLG="${CFLAGS}"
+
+post-patch:
+
+ @${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.pre_sed
+ @${SED} -e 's#-O2#${CFLAGS}#' \
+ ${WRKSRC}/Makefile.pre_sed > ${WRKSRC}/Makefile
+
+do-install:
+
+ ${INSTALL_PROGRAM} ${WRKSRC}/nttcp ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/nttcp.1 ${PREFIX}/man/man1/
+
+.include <bsd.port.mk>