aboutsummaryrefslogtreecommitdiff
path: root/net/nusoap/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-09-17 01:37:28 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-09-17 01:37:28 +0000
commitecd7a9f091dd6e85e30eb524678c530b8561ebc2 (patch)
treecc0c529a7a2a5f3d84f214bfbcab0869095be86c /net/nusoap/Makefile
parent957d2a35c5aeeed0753029d33cca52def8a3656a (diff)
downloadports-ecd7a9f091dd6e85e30eb524678c530b8561ebc2.tar.gz
ports-ecd7a9f091dd6e85e30eb524678c530b8561ebc2.zip
Notes
Diffstat (limited to 'net/nusoap/Makefile')
-rw-r--r--net/nusoap/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/nusoap/Makefile b/net/nusoap/Makefile
new file mode 100644
index 000000000000..d65a7d265633
--- /dev/null
+++ b/net/nusoap/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: nusoap
+# Date created: 2007-09-07
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nusoap
+PORTVERSION= 0.7.2
+CATEGORIES= net www
+MASTER_SITES= SOURCEFORGE
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= SOAP Toolkit for PHP
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PHP= curl zlib
+USE_ZIP= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${CP} ${WRKSRC}/lib/* ${DATADIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/samples/* ${EXAMPLESDIR}
+
+.include <bsd.port.post.mk>