aboutsummaryrefslogtreecommitdiff
path: root/net/ocserv
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2016-10-07 22:34:04 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2016-10-07 22:34:04 +0000
commit661d7552179739bb242b3f33da67244657ed4f29 (patch)
tree3ab17752d57b350845b303ecdf4441251223b13e /net/ocserv
parent793cb89e7d5ae2889b2e8d06799dba70eb20e6ec (diff)
Notes
Diffstat (limited to 'net/ocserv')
-rw-r--r--net/ocserv/Makefile3
-rw-r--r--net/ocserv/distinfo6
-rw-r--r--net/ocserv/files/patch-src_config.c19
3 files changed, 15 insertions, 13 deletions
diff --git a/net/ocserv/Makefile b/net/ocserv/Makefile
index dc27863d28eb..1bb2ccc405b4 100644
--- a/net/ocserv/Makefile
+++ b/net/ocserv/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ocserv
-PORTVERSION= 0.11.4
-PORTREVISION= 1
+PORTVERSION= 0.11.5
CATEGORIES= net security
MASTER_SITES= ftp://ftp.infradead.org/pub/ocserv/
diff --git a/net/ocserv/distinfo b/net/ocserv/distinfo
index 654a7d8a2fe6..b1ac2a091511 100644
--- a/net/ocserv/distinfo
+++ b/net/ocserv/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1470657990
-SHA256 (ocserv-0.11.4.tar.xz) = f0c50cb92492808241086252f5b5d4f3bd99d63a09d544639074fbd0465f97b7
-SIZE (ocserv-0.11.4.tar.xz) = 755112
+TIMESTAMP = 1474711445
+SHA256 (ocserv-0.11.5.tar.xz) = 2a80e32e538044fba7745fd2a0cfaa27a398097fb8d4d684c1142118b69219cb
+SIZE (ocserv-0.11.5.tar.xz) = 758252
diff --git a/net/ocserv/files/patch-src_config.c b/net/ocserv/files/patch-src_config.c
index 28bbb2e9bb92..628e842b156e 100644
--- a/net/ocserv/files/patch-src_config.c
+++ b/net/ocserv/files/patch-src_config.c
@@ -1,7 +1,7 @@
---- src/config.c.orig 2015-09-04 19:27:22 UTC
+--- src/config.c.orig 2016-09-22 13:51:31 UTC
+++ src/config.c
-@@ -51,8 +51,7 @@
- #include <tlslib.h>
+@@ -54,8 +54,7 @@
+ #include <occtl/ctl.h>
#include "common-config.h"
-#define OLD_DEFAULT_CFG_FILE "/etc/ocserv.conf"
@@ -10,16 +10,16 @@
static char pid_file[_POSIX_PATH_MAX] = "";
static char cfg_file[_POSIX_PATH_MAX] = DEFAULT_CFG_FILE;
-@@ -416,7 +415,7 @@ static void figure_auth_funcs(struct per
+@@ -436,7 +435,7 @@ static void figure_auth_funcs(struct per
}
talloc_free(auth[j]);
}
-- fprintf(stderr, "Setting '%s' as primary authentication method\n", config->auth[0].name);
-+ /* fprintf(stderr, "Setting '%s' as primary authentication method\n", config->auth[0].name); */
+- fprintf(stderr, NOTESTR"setting '%s' as primary authentication method\n", config->auth[0].name);
++ /* fprintf(stderr, NOTESTR"Setting '%s' as primary authentication method\n", config->auth[0].name); */
} else {
unsigned x = config->auth_methods;
/* Append authentication methods (alternative options) */
-@@ -586,9 +585,6 @@ size_t urlfw_size = 0;
+@@ -663,11 +662,8 @@ size_t urlfw_size = 0;
#endif
pov = configFileLoad(file);
@@ -27,5 +27,8 @@
- pov = configFileLoad(OLD_DEFAULT_CFG_FILE);
-
if (pov == NULL) {
- fprintf(stderr, "Error loading config file %s\n", file);
+- fprintf(stderr, ERRSTR"cannot load config file %s\n", file);
++ fprintf(stderr, ERRSTR"Cannot load config file %s\n", file);
exit(1);
+ }
+