aboutsummaryrefslogtreecommitdiff
path: root/net/onion-fec
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-04-05 03:49:52 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-04-05 03:49:52 +0000
commit739be181cc65aaca5c81fc7be15fdeb54958800c (patch)
treecc317f9ed9e62d7403e54830a01277417201cf20 /net/onion-fec
parent77e1e587719b3e334adcad9e05c490c0da203ffd (diff)
Notes
Diffstat (limited to 'net/onion-fec')
-rw-r--r--net/onion-fec/Makefile58
-rw-r--r--net/onion-fec/distinfo3
-rw-r--r--net/onion-fec/pkg-descr12
3 files changed, 73 insertions, 0 deletions
diff --git a/net/onion-fec/Makefile b/net/onion-fec/Makefile
new file mode 100644
index 000000000000..904834ef8b6e
--- /dev/null
+++ b/net/onion-fec/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: Java OnionNetworks FEC
+# Date created: Wed Apr 5 03:10:31 UTC 2006
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fec
+PORTVERSION= 1.0.3
+CATEGORIES= net java
+MASTER_SITES= http://onionnetworks.com/downloads/
+PKGNAMEPREFIX= onion-
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Java Forward Error Correction (FEC) library from OnionNetworks
+
+BUILD_DEPENDS= \
+ ${JAVALIBDIR}/log4j.jar:${PORTSDIR}/devel/log4j
+
+USE_ZIP= yes
+USE_ANT= yes
+JAVA_BUILD= jdk
+USE_JAVA= 1.4+
+JAVA_OS= native
+ALL_TARGET= jars
+
+.ifndef(NOPORTDOCS)
+ALL_TARGET+= javadoc
+
+PORTDOCS+= javadoc
+.endif
+
+# override DEFAULT
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+JAVADOC_WRKSRC= ${WRKSRC}/javadoc
+
+# jars
+JAR_FILES+= \
+ onion-common.jar \
+ onion-fec.jar
+PLIST_FILES+= ${JAR_FILES:S,^,%%JAVAJARDIR%%/,}
+
+pre-build:
+ @${LN} -sf ${JAVALIBDIR}/log4j.jar ${WRKSRC}/lib
+
+do-install:
+.ifndef(NOPORTDOCS)
+# line taken from textproc/xerces-j maintained by hq@FreeBSD.org
+ @cd ${JAVADOC_WRKSRC} && \
+ ${FIND} . -type d -exec ${MKDIR} "${DOCSDIR}/javadoc/{}" \; && \
+ ${FIND} . -not -type d -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/javadoc/{}" \;
+.endif
+.for jar in ${JAR_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/lib/${jar} ${JAVAJARDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/net/onion-fec/distinfo b/net/onion-fec/distinfo
new file mode 100644
index 000000000000..d3b75adac4e8
--- /dev/null
+++ b/net/onion-fec/distinfo
@@ -0,0 +1,3 @@
+MD5 (fec-1.0.3.zip) = 484f8629cca2db44a3cfd6adfc543c2e
+SHA256 (fec-1.0.3.zip) = 2b23956854800b85a0d2eec11ab0940daec44e4c828b78782686efe8511a7d12
+SIZE (fec-1.0.3.zip) = 745195
diff --git a/net/onion-fec/pkg-descr b/net/onion-fec/pkg-descr
new file mode 100644
index 000000000000..bb87adf83269
--- /dev/null
+++ b/net/onion-fec/pkg-descr
@@ -0,0 +1,12 @@
+[ excerpt from developer's web site with modifications ]
+
+Forward Error Correction (FEC) is an essential building block of
+any satellite or IP multicast based content distribution system.
+Our library is the fastest and most mature Java FEC library available.
+It features:
+
+o Fast multi-threaded I/O routines for encoding and decoding files
+o FEC codec plugin interface
+o Cryptograhic hashes can be used for checking file integrity
+
+WWW: http://onionnetworks.com/developers/