aboutsummaryrefslogtreecommitdiff
path: root/net/onioncat/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-10 02:24:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-10 02:24:54 +0000
commit98915213c0383601e6bf90120143448f4c8d2737 (patch)
tree7cb344eed016319a1214d44267d4fc4dcbd6b3e7 /net/onioncat/Makefile
parent20420eb9da9771d7c901e257f07777a78d380f29 (diff)
downloadports-98915213c0383601e6bf90120143448f4c8d2737.tar.gz
ports-98915213c0383601e6bf90120143448f4c8d2737.zip
Notes
Diffstat (limited to 'net/onioncat/Makefile')
-rw-r--r--net/onioncat/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/onioncat/Makefile b/net/onioncat/Makefile
new file mode 100644
index 000000000000..e3e3c688f738
--- /dev/null
+++ b/net/onioncat/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: onioncat
+# Date created: 2010-05-09
+# Whom: <ports@c0decafe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= onioncat
+PORTVERSION= 0.2.1
+CATEGORIES= net security
+MASTER_SITES= http://www.cypherpunk.at/ocat/download/Source/stable/
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= An IP-Transparent Tor Hidden Service Connector
+
+RUN_DEPENDS= tor:${PORTSDIR}/security/tor
+
+GNU_CONFIGURE= yes
+
+USE_RC_SUBR= ${PORTNAME}
+MAN1= ocat.1
+PLIST_FILES= bin/ocat
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ocat ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/ocat.1 ${PREFIX}/man/man1/ocat.1
+
+.include <bsd.port.post.mk>