aboutsummaryrefslogtreecommitdiff
path: root/net/ooni-mini/Makefile
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2020-10-23 07:35:01 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2020-10-23 07:35:01 +0000
commit12ae6519d7edb46172b175376462ceb2b46b22c5 (patch)
tree78af73be5eff833bc7b042641e1ae9175fed7e9b /net/ooni-mini/Makefile
parent5cbe76d12c1115f33eeaef141c04f800c22fd28f (diff)
downloadports-12ae6519d7edb46172b175376462ceb2b46b22c5.tar.gz
ports-12ae6519d7edb46172b175376462ceb2b46b22c5.zip
Notes
Diffstat (limited to 'net/ooni-mini/Makefile')
-rw-r--r--net/ooni-mini/Makefile32
1 files changed, 18 insertions, 14 deletions
diff --git a/net/ooni-mini/Makefile b/net/ooni-mini/Makefile
index fb0f78c701c2..fe5f40fe6c42 100644
--- a/net/ooni-mini/Makefile
+++ b/net/ooni-mini/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ooni-mini
DISTVERSIONPREFIX= v
-DISTVERSION= 0.16.0
+DISTVERSION= 0.18.0
CATEGORIES= net www benchmarks
MAINTAINER= egypcio@FreeBSD.org
@@ -18,7 +18,9 @@ USE_GITHUB= yes
USE_GITLAB= nodefault
CPE_VENDOR= torproject
-GO_BUILDFLAGS= -tags=ooni,nomk -ldflags '-s -w -extldflags "-static"'
+
+# # github.com/ooni/probe-engine/blob/master/readme_compiletimecheck.go#L6
+GO_BUILDFLAGS= -tags=ooni,nomk,DISABLE_QUIC -ldflags '-s -w -extldflags "-static"'
GO_TARGET= ./cmd/miniooni
GH_ACCOUNT= ooni
GH_PROJECT= probe-engine
@@ -29,11 +31,10 @@ GH_TUPLE= AndreasBriese:bbloom:28f7e881ca57:andreasbriese_bbloom/vendor/github.c
Psiphon-Labs:goarista:d002785f4c67:psiphon_labs_goarista/vendor/github.com/Psiphon-Labs/goarista \
Psiphon-Labs:goptlib:c0e32a7a3464:psiphon_labs_goptlib/vendor/github.com/Psiphon-Labs/goptlib \
Psiphon-Labs:net:f5d60dada742:psiphon_labs_net/vendor/github.com/Psiphon-Labs/net \
- Psiphon-Labs:psiphon-tunnel-core:10cb0192d244:psiphon_labs_psiphon_tunnel_core/vendor/github.com/Psiphon-Labs/psiphon-tunnel-core \
+ Psiphon-Labs:psiphon-tunnel-core:3a44f293ada3:psiphon_labs_psiphon_tunnel_core/vendor/github.com/Psiphon-Labs/psiphon-tunnel-core \
Psiphon-Labs:quic-go:474e74c89fab:psiphon_labs_quic_go/vendor/github.com/Psiphon-Labs/quic-go \
Psiphon-Labs:tls-tris:7d791789810f:psiphon_labs_tls_tris/vendor/github.com/Psiphon-Labs/tls-tris \
agl:ed25519:5312a6153412:agl_ed25519/vendor/github.com/agl/ed25519 \
- ahf:goptlib:7d56ec4:ahf_goptlib/vendor/git.torproject.org/pluggable-transports/goptlib.git \
apex:log:v1.9.0:apex_log/vendor/github.com/apex/log \
aristanetworks:goarista:4cb0e71f3c0e:aristanetworks_goarista/vendor/github.com/aristanetworks/goarista \
armon:go-proxyproto:5b7edb60ff5f:armon_go_proxyproto/vendor/github.com/armon/go-proxyproto \
@@ -48,23 +49,25 @@ GH_TUPLE= AndreasBriese:bbloom:28f7e881ca57:andreasbriese_bbloom/vendor/github.c
dgraph-io:badger:3a87f6d9c273:dgraph_io_badger/vendor/github.com/dgraph-io/badger \
dgryski:go-farm:2de33835d102:dgryski_go_farm/vendor/github.com/dgryski/go-farm \
dsnet:compress:v0.0.1:dsnet_compress/vendor/github.com/dsnet/compress \
- elazarl:goproxy:a96fa3a31826:elazarl_goproxy/vendor/github.com/elazarl/goproxy \
+ elazarl:goproxy:0581fc3aee2d:elazarl_goproxy/vendor/github.com/elazarl/goproxy \
fatih:color:v1.7.0:fatih_color/vendor/github.com/fatih/color \
+ florianl:go-nfqueue:a2f196e98ab0:florianl_go_nfqueue/vendor/github.com/florianl/go-nfqueue \
gobwas:glob:f00a7392b439:gobwas_glob/vendor/github.com/gobwas/glob \
golang:crypto:75b288015ac9:golang_crypto/vendor/golang.org/x/crypto \
- golang:net:3edf25e44fcc:golang_net/vendor/golang.org/x/net \
+ golang:net:5d4f70055728:golang_net/vendor/golang.org/x/net \
golang:protobuf:v1.3.3:golang_protobuf/vendor/github.com/golang/protobuf \
- golang:sys:d785dc25833f:golang_sys/vendor/golang.org/x/sys \
+ golang:sys:157a740278f4:golang_sys/vendor/golang.org/x/sys \
golang:text:v0.3.2:golang_text/vendor/golang.org/x/text \
- google:go-cmp:v0.5.1:google_go_cmp/vendor/github.com/google/go-cmp \
+ google:go-cmp:v0.5.2:google_go_cmp/vendor/github.com/google/go-cmp \
+ google:gopacket:df1bbd09a561:google_gopacket/vendor/github.com/google/gopacket \
google:gxui:f85e0a97b3a4:google_gxui/vendor/github.com/google/gxui \
google:martian:v3.0.0:google_martian_v3/vendor/github.com/google/martian/v3 \
google:shlex:e7afc7fbc510:google_shlex/vendor/github.com/google/shlex \
- google:uuid:v1.1.1:google_uuid/vendor/github.com/google/uuid \
+ google:uuid:v1.1.2:google_uuid/vendor/github.com/google/uuid \
gorilla:websocket:v1.4.2:gorilla_websocket/vendor/github.com/gorilla/websocket \
grafov:m3u8:6ab8f28ed427:grafov_m3u8/vendor/github.com/grafov/m3u8 \
hashicorp:golang-lru:v0.5.4:hashicorp_golang_lru/vendor/github.com/hashicorp/golang-lru \
- iancoleman:strcase:v0.1.0:iancoleman_strcase/vendor/github.com/iancoleman/strcase \
+ iancoleman:strcase:v0.1.2:iancoleman_strcase/vendor/github.com/iancoleman/strcase \
juju:ratelimit:f60b32039441:juju_ratelimit/vendor/github.com/juju/ratelimit \
konsorten:go-windows-terminal-sequences:v1.0.1:konsorten_go_windows_terminal_sequences/vendor/github.com/konsorten/go-windows-terminal-sequences \
marten-seemann:qpack:v0.1.0:marten_seemann_qpack/vendor/github.com/marten-seemann/qpack \
@@ -75,20 +78,21 @@ GH_TUPLE= AndreasBriese:bbloom:28f7e881ca57:andreasbriese_bbloom/vendor/github.c
miekg:dns:v1.1.31:miekg_dns/vendor/github.com/miekg/dns \
montanaflynn:stats:v0.6.3:montanaflynn_stats/vendor/github.com/montanaflynn/stats \
oschwald:geoip2-golang:v1.4.0:oschwald_geoip2_golang/vendor/github.com/oschwald/geoip2-golang \
- oschwald:maxminddb-golang:v1.7.0:oschwald_maxminddb_golang/vendor/github.com/oschwald/maxminddb-golang \
+ oschwald:maxminddb-golang:v1.6.0:oschwald_maxminddb_golang/vendor/github.com/oschwald/maxminddb-golang \
patrickmn:go-cache:v2.1.0:patrickmn_go_cache/vendor/github.com/patrickmn/go-cache \
- pborman:getopt:v2.1.0:pborman_getopt/vendor/github.com/pborman/getopt \
+ pborman:getopt:v2.1.0:pborman_getopt_v2/vendor/github.com/pborman/getopt \
pion:stun:v0.3.5:pion_stun/vendor/github.com/pion/stun \
pkg:errors:v0.9.1:pkg_errors/vendor/github.com/pkg/errors \
redjack:marionette:360dd8f58226:redjack_marionette/vendor/github.com/redjack/marionette \
refraction-networking:gotapdance:3a6e1938ad70:refraction_networking_gotapdance/vendor/github.com/refraction-networking/gotapdance \
refraction-networking:utls:186025ac7b77:refraction_networking_utls/vendor/github.com/refraction-networking/utls \
- rogpeppe:go-internal:v1.6.1:rogpeppe_go_internal/vendor/github.com/rogpeppe/go-internal \
+ rogpeppe:go-internal:v1.6.2:rogpeppe_go_internal/vendor/github.com/rogpeppe/go-internal \
ryanuber:go-glob:256dc444b735:ryanuber_go_glob/vendor/github.com/ryanuber/go-glob \
sergeyfrolov:bsbuffer:94e85abb8507:sergeyfrolov_bsbuffer/vendor/github.com/sergeyfrolov/bsbuffer \
sirupsen:logrus:v1.4.2:sirupsen_logrus/vendor/github.com/sirupsen/logrus \
smartystreets:goconvey:v1.6.4:smartystreets_goconvey/vendor/github.com/smartystreets/goconvey \
syndtr:gocapability:db04d3cc01c8:syndtr_gocapability/vendor/github.com/syndtr/gocapability \
+ torbsd:goptlib:v1.1.0:torbsd_goptlib/vendor/git.torproject.org/pluggable-transports/goptlib.git \
uber-go:atomic:ca680462431f:uber_go_atomic/vendor/go.uber.org/atomic \
uber-go:multierr:ddea229ff1df:uber_go_multierr/vendor/go.uber.org/multierr \
uber-go:zap:67bc79d13d15:uber_go_zap/vendor/go.uber.org/zap \
@@ -97,7 +101,7 @@ GH_TUPLE= AndreasBriese:bbloom:28f7e881ca57:andreasbriese_bbloom/vendor/github.c
GL_TUPLE= yawning:bsaes:26d1add596b6d800bdeeb3bc3b2c7b316c056b6d:yawning_bsaes/vendor/git.schwanenlied.me/yawning/bsaes.git \
yawning:obfs4:2d8f3c8bbfd7a7ca931738a64c2f6e97b7332d9e:yawning_obfs4/vendor/gitlab.com/yawning/obfs4.git \
- yawning:utls:dd99191913e03b2cd62655cd260d79187fbf8a9f:yawning_utls/vendor/gitlab.com/yawning/utls.git
+ yawning:utls:ad258eb64575fd468dbd2f93ef229df5f7fe72b4:yawning_utls/vendor/gitlab.com/yawning/utls.git
PLIST_FILES= bin/miniooni