aboutsummaryrefslogtreecommitdiff
path: root/net/opal/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-08 05:14:22 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-08 05:14:22 +0000
commit9b7c432b651bad6f5851c8eae9ebf96dccafb16e (patch)
tree800f6f70ea04f27d1f5894cc5418009c3f08d51b /net/opal/Makefile
parentaefb5788e6dbeb146d40c45fa38cd36509a2c121 (diff)
downloadports-9b7c432b651bad6f5851c8eae9ebf96dccafb16e.tar.gz
ports-9b7c432b651bad6f5851c8eae9ebf96dccafb16e.zip
Notes
Diffstat (limited to 'net/opal/Makefile')
-rw-r--r--net/opal/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index a55dc216386c..1548e3c442a9 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opal
PORTVERSION= 2.2.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.voxgratia.org/releases/
DISTNAME= ${PORTNAME}-v${PORTVERSION:S/./_/g}-src-
@@ -24,8 +25,24 @@ USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS= yes
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.ifdef (WITH_FFMPEG)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+CONFIGURE_ARGS+= --enable-h263avcodec=${LOCALBASE}/include/ffmpeg
+.endif
+
+.ifdef (WITH_SPEEX)
+LIB_DEPENDS+= speex.3:${PORTSDIR}/audio/speex-devel
+BUILD_DEPENDS+= ${LOCALBASE}/include/speex/speex_echo.h:${PORTSDIR}/audio/speex-devel
+CONFIGURE_ARGS+= --enable-localspeex=no
+.else
+CONFIGURE_ARGS+= --enable-localspeex=yes
+.endif
+
+.include <bsd.port.post.mk>