aboutsummaryrefslogtreecommitdiff
path: root/net/opal/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-04-05 22:23:15 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-04-05 22:23:15 +0000
commit811d149205fc0b86d8137431a68e888c6654ae17 (patch)
tree039bc18c46e2396794601cf3f468b66050df2976 /net/opal/Makefile
parentd5aef7a6c07362820eacbc450e5bebb8906978c5 (diff)
Notes
Diffstat (limited to 'net/opal/Makefile')
-rw-r--r--net/opal/Makefile27
1 files changed, 7 insertions, 20 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index 205f557afca5..89e4771a470f 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -5,39 +5,26 @@
# $FreeBSD$
#
-PORTNAME= openh323
-PORTVERSION= 1.17.3
-PORTREVISION= 2
+PORTNAME= opal
+PORTVERSION= 2.2.1
CATEGORIES= net
MASTER_SITES= http://www.voxgratia.org/releases/
DISTNAME= ${PORTNAME}-v${PORTVERSION:S/./_/g}-src-
EXTRACT_SUFX= tar.gz
-MAINTAINER= steve@energistic.com
-COMMENT= A H323 Video Conferencing library
+MAINTAINER= jbq@caraldi.com
+COMMENT= VoIP abstraction library
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
- pt_r.1:${PORTSDIR}/devel/pwlib
+LIB_DEPENDS= pt_r.1:${PORTSDIR}/devel/pwlib
WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
-USE_BISON= yes
USE_GMAKE= yes
-USE_OPENLDAP= yes
USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-ALL_TARGET= optshared
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" BUILDTIME="YES"
-MAKE_ENV= BUILDTIME="YES"
-NO_FILTER_SHLIBS= yes
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
-
-.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
-CFLAGS+= -fPIC
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>